Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been using Fiddler for years, but now, on Windows 7 (64 bit) I cannot get it to monitor traffic from IE 8.

With the Firefox add-on, it is able to monitor Firefox traffic with no problem.

This is not related to monitoring HTTPS traffic, or traffic to localhost.

I've tried running IE and/or Fiddler with "Run as Administrator", but no luck.

The best clue to the problem that I have is that in IE8, the "Local Area Network (LAN) Settings" dialog accessed from "LAN Settings" in the Internet Options / Connections tab is all grayed out.

I have two Windows 7, 64 bit computers, both on the same LAN. One works fine, the other has these settings grayed out, and a note on the Connections tab: "Some settings are managed by your system administrator". However, the system administrator has NOT set any.

Any ideas?

share|improve this question
    
It seems to be something to do with the Group Policies in the Active Director, but we can't find any that are preventing this change. –  Glen Little Jul 14 '10 at 19:14
add comment

3 Answers

up vote 3 down vote accepted

Turns out that an Active Directory Group Policy Object (GPO) was responsible for the problem.

In the Policy, it is under:

Computer Configuration
  Administrative Templates
    Windows Components
      Internet Explorer

and is called

Make proxy settings per-machine (rather than per-user)

If that setting is enabled, then Fiddler (Fiddler2) cannot adjust the proxy settings on the local computer when it starts.

After making that change on the server, all users will eventually get the new setting. To get the new setting immediately, run this command on any computer:

gpupdate /target:Computer /wait:0
share|improve this answer
add comment

Here is a temporary solution:

  1. Run IE as an administrator
  2. Tools > Internet Options > Connections > LAN Settings
  3. Check "Use a proxy server for your LAN ..."
  4. Address: add localhost
  5. Port: add 8888

Fiddler seems to use this port, and the reason Fiddler can't capture the traffic is that IE by default is using a different port.

share|improve this answer
    
I'd still like to be able to run it without being Admin. –  Glen Little Jul 14 '10 at 18:25
add comment

Just wanted to add for people with windows 7 home editions, that don't have the group policy editor:

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\Internet Settings]
"ProxySettingsPerUser"=dword:00000000

For other group policy settings: http://www.microsoft.com/en-us/download/details.aspx?id=25250

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.