Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I followed these instructions to create self-signed SSL (I opened SelfSSL and typed selfssl /T).

When I access https://localhost/ than it works, but when I try to access it remotely (i set up my router to port forward to localhost), for example https://myip the page does not load. Also, I noticed one other thing. When I access localhost locally then I am asked to enter user/pass, but if I access remotely the I get the following warning:

Under Construction The site you were trying to reach does not currently have a default page. It may be in the process of being upgraded and configured. ...

I don't know if it is related with this but I hope someone know the answer.

Thanks, Ile

share|improve this question
    
What port are you forwarding in your router? – heavyd Apr 27 '10 at 18:29
    
I am forwarding port 8080 – ile Apr 27 '10 at 18:34
up vote 0 down vote accepted

Here are a couple things I see that may be wrong.

  1. HTTPS uses port 443 not 80 or 8080, so if you are just specifying https://myip then it will try to access port 443, you either need to forward 443 or specify a port https://myip:8080. If you go the 8080 route, you will need to be sure that IIS is listening for SSL connections on port 8080, not normal HTTP/port 80 traffic.
  2. You said in your port forwarding rule you are forwarding to localhost. Are you really forwarding to localhost/127.0.0.1 or are you using your internal IP? You need to make sure it is your internal IP address (likely 192.168.x.x).
share|improve this answer
    
I am not currently by router so I draw settings - Are you suggesting that I should set it up like this: img440.imageshack.us/img440/2807/port.gif – ile Apr 27 '10 at 18:57
    
Looks right, as long as you haven't changed the port that IIS is listening on. – heavyd Apr 27 '10 at 19:03
    
Thanks, I'll try it tommorow morning and let you know if it works – ile Apr 27 '10 at 19:09
    
I did what you suggested and it works. Thanks once again! – ile Apr 28 '10 at 6:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .