Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a lot of Excel sheets for all sorts of things - but none has ever acted up like this one here:

troubled excel sheet

This used to be a totally normal Excel 2007 sheet which I was able to resize, maximize etc. - but not anymore. The MDI child window is fixed, both in position and size. I cannot move it around, more can I maximize it to use the full size of the screen anymore. I cannot double-click on it's title bar to maximize it either :-(

What happened? What can I do to "undo" whatever I did to it.

Any ideas? I tried to share / undo sharing, I tried to protect / unprotect the sheet - nothing seems to work...

share|improve this question
1  
@Chris The MDI window that contains the spreadsheet doesn't have any controls (Maximize, Minimize, etc.). –  Michael Todd Apr 27 '10 at 22:46
    
@CHris Thompson: yes, the MDI window is fixed, in position and size, and I can't seem to get it to resize or move anymore.... –  marc_s Apr 28 '10 at 5:10
1  
i think you need to remove the glass filter you have over your screen ;) –  RCIX Apr 30 '10 at 3:15
    
@RCIX yeah right :-) –  marc_s Apr 30 '10 at 19:26

3 Answers 3

up vote 12 down vote accepted

Go to Review > Changes > Protect Workbook, and uncheck Protect Structure and Windows option. If you have set a password for it, Excel will prompt you to enter it. Otherwise, just hit enter to remove the structure and window protection.

On Excel 2011 for Mac, the process is only slighty different. On the Review tab, under Protection, click Workbook to remove the protection. See also the official online help.

share|improve this answer
    
Thanks - I can see that that option "Protect Structure and Windows" is checked - but it's grayed out, I can't uncheck it..... any ideas?? –  marc_s Apr 28 '10 at 19:18
    
Attempt #2 - solved it! The workbook was shared, for some weird reason. Once I've removed the sharing, I was able to uncheck that "Protect Structure and Windows" option and that solved it - thanks so much !! –  marc_s Apr 28 '10 at 19:20
2  
This means that your workbook is protected. To remove protection, under Review > Changes, you should click on Unprotect Shared Workbook (which stands at the upper-right corner of Changes box). Then you can uncheck Protect Structure and Windows option. –  Mehper C. Palavuzlar Apr 28 '10 at 19:29
    
While I was writing my above comment, you solved it yourself. You're welcome, and good luck with Excel ;) –  Mehper C. Palavuzlar Apr 28 '10 at 19:31

One way that can be done is through VBA. See here: http://support.microsoft.com/kb/137033

And another VBA method: http://www.mrexcel.com/forum/showthread.php?t=41720

See if there are any macros associated with this sheet.

It's also possible that this is due to Workbook protection: http://webcache.googleusercontent.com/search?q=cache:02brqfAzeN4J:office.microsoft.com/en-us/excel/HP052035251033.aspx+remove+maximize+minimize+spreadsheet+window+excel&cd=3&hl=en&ct=clnk&gl=us&client=firefox-a

UPDATE: I've been able to duplicate that issue in Excel 2007, and it is a worksheet protection issue.

In Excel 2007, select the Review tab, then click the Protect Workbook button and uncheck Protect Structures and Windows.

share|improve this answer
    
Unfortunately, that "workbook protection" link refers to Excel 2003, and in Excel 2007, there's no "Tools" / "Protection" menu :-( –  marc_s Apr 28 '10 at 5:14

My guess is whatever is wrong the answer is in the "View" menu.

Try double clicking the title bar where it says "Einkuaf2010" to maximize it.

share|improve this answer
    
Tried that - no luck - nothing happens –  marc_s Apr 28 '10 at 5:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.