Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I guess I got a virus or something and it's screwing up my connections. I'm able to browse fine in Firefox with proxies disabled, but other than that I have no connection.

Currently, I need to install a program, but it requires an internet connection, and it keeps running into connection errors - same problem the other day when trying to register a product I purchased.

I usually can figure this stuff out, but this one has me baffled.

Any help troubleshooting this would be much appreciated.

share|improve this question
add comment

3 Answers

Check your IE settings. Under Tools|Internet Options|Connections Click on "LAN SETTINGS" and clear all the check boxes. See if that helps.

share|improve this answer
add comment

I'm sure this is probably a dupe question, but you'll want to download a program called ComboFix and run it as well as resetting your Internet Explorer settings. That will most likely resolve your problem, but there still may be infected files on your computer.

If you want to make sure your computer is COMPLETELY fixed, do the following:

  1. Download the EXE Registry Fix, ComboFix and MBAM. If you cannot do this from your PC, use another computer and then transport the files via flash drive to your infected PC.
  2. Boot into "Safe Mode with Networking" on the infected PC. This is done by pressing F8 after your computer POSTs, but before it says "Loading Windows".
  3. Login under your main user account (you must have administrative privs though.)
  4. First run the EXE Registry Fix.
  5. Next, install and UPDATE MBAM. If you do not update it, you are wasting your time.
  6. Run a full scan with MBAM and remove everything it finds. It will probably ask you to reboot afterward.
  7. If it doesn't ask you to reboot, reboot manually. Do not go back into Safe Mode.
  8. When Windows loads, run ComboFix. It will take a while to run. Follow the instructions on the ComboFix website to properly use that program.
  9. Reboot if ComboFix doesn't do it for you.
  10. In Internet Explorer, go to Tools > Internet Options > Advanced > Reset and perform a reset. This will not reset your personal settings or saved passwords.
share|improve this answer
add comment

Hmm...

Working properly now.

The only 2 things I did was Uncheck the LAN boxes as Sarge mentioned and ran the EXE Registry Fix. Not sure which one would have done the trick, but I'm assuming it was the LAN settings. Not sure why those got that way. Only started experiencing this issue short after getting a virus (which didn't cause too much trouble, from what I see)

Thanks for the tips guys.. (thanks for the time James, maybe that tip will be useful for others)

Cheers

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.