Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I open a file with some UTF-8 text in it the characters show up as boxes.

I think I have a font missing, because I can safely edit these boxes and the changes will turn out correctly when I look at them in another text editor (for example from Vim in terminal).

Also at startup Emacs prints out the following warning:

Warning: no fonts matching `-*-fixed-medium-r-normal-*-16-*-*-*-*-*-iso8859-1' available [2 times]

I have tried installing several X.org font packages to my system but that doesn't seem to help.

Using GNU Emacs 22.3

share|improve this question

3 Answers 3

up vote 3 down vote accepted

Try and set DejaVu Sans Mono as the font. That's a font for Unicode that is normally installed by default on any Linux distribution.

share|improve this answer
    
This kind of solved my problem, as to use DejaVu Sans Mono font I had to upgrade to Emacs 23, as 22 doesn't support TrueType fonts. Apparently after upgrade Emacs automagically selected DejaVu Sans Mono as its default font. –  Rene Saarsoo Jul 27 '09 at 14:01
    
Glad it helped! –  Mike McQuaid Jul 27 '09 at 14:03
    
Emacs 23 added xft support which makes life much more livable in the world of fonts and emacs. –  baudtack Dec 23 '09 at 7:24

The fonts error is probably a red herring. This message usually comes up because Emacs thinks it should use a font this specification for some of its output. If you need/want to fix it then finding the faulty specification and fixing it is the recommended route (e.g. http://braeburn.aquamacs.org/code/master/etc/PROBLEMS).

share|improve this answer
1  
Upgrading to Emacs 23 also seemed to remove this warning message. –  Rene Saarsoo Jul 27 '09 at 14:02

Unicode (name or hex):

http://stackoverflow.com/questions/1145889/emacs-xterm-mousepad-c-unicode-and-utf-8-trying-to-make-sense-of-it-all

share|improve this answer
    
What do you mean by "name or hex"? And what should I look for in that question you pointed out? –  Rene Saarsoo Jul 27 '09 at 9:31
    
There are some answer for this problem .. –  joe Jul 27 '09 at 9:39
    
If you mean (prefer-coding-system 'utf-8) then I do have that in my .emacs file. I also tried adding all the following lines, but that didn't help. –  Rene Saarsoo Jul 27 '09 at 9:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.