Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to create partitions for a Slackware installation on my computer (beside Windows 7) just to have a nice distribution running mostly for school but when I run fdisk and print the partition table I get the following message:

Partition x does not end on cylinder boundary.

(In my case x = 1, just using x to help googlers.)

I must say I'm using a RAID card (AMCC 3ware 9500S SATA RAID Controller). Maybe this is the problem.

How can I fix this without losing any data?

share|improve this question

migrated from stackoverflow.com Apr 29 '10 at 0:39

This question came from our site for professional and enthusiast programmers.

    
is this a real RAID card or a fakeRAID? –  quack quixote Apr 29 '10 at 2:01

1 Answer 1

I don't think you have a problem.

If your partitioning tool is seeing the RAID array properly, the RAIDness of the disk being partitioned doesn't matter.

I have heard that the actual layout of a modern disk is nothing like what is reported in the partitioning tool - so what is seen as a cylinder boundary in the partitioning tool probably isn't one anyway. The warning is just there for historical reasons.

The reason for the warning stems from the fact that MS-DOS (I think, but may be wrong - it hasn't been very relevant for ages) needed partitions that started and ended on a cylinder boundary. Windows carried on the tradition of making sure that partitions started ended on a cylinder boundary for no reason, externally created partitions that didn't end on the boundary worked ok.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.