Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Linksys WRT54G v8 with DD-WRT micro installed. I find in high load situations (downloading a torrent for example) the router will simply restart several times.

Any ideas what's wrong? Should I revert to the stock firmware?

share|improve this question

4 Answers 4

up vote 2 down vote accepted

This is actually overheating issue OR the number of max connection is not optimize... Go in the Administration tabs, and scroll all way down, you'll see this :

alt text

You can set it to the max with no problem, and also reduce the timeout to 30. I ran a WRT54G V5 with those settings for months before switching to a DIR-655, and I never had a problem after configuring the maximum port that way.

share|improve this answer
    
This seems to have fixed it...thanks! –  Ben Baril Apr 29 '10 at 18:11

Check how hot the router is, I'm not too sure about the WRT but my Netgear DG834 exhibited the same behaviour and was very hot when it happened. Putting it in a more ventilated place solved it for me.

share|improve this answer

I had similar behavior with DD-WRT and most of time it was because of tight memory conditions.

Since most of memory was taken with tracking torrent connections, I solved it by limiting number of simultaneous connections from 4096 to 1024.

Check memory tab to see whether same thing applies to you also.

share|improve this answer
    
This is actually weird, because I resolved my problem by upping the number of concurrent connexion here in my case! Reducing the number of connection was making the problem reappears as soon as I was applying settings... Weird.. Maybe it's because V5 have more RAM than V8.. –  Marc-Andre R. Apr 29 '10 at 13:56

I had this problem with a different model, which turned out to be an overheating problem. Upgrading to the latest firmware solved my particular problem, but this may not be a solution for you.

But I'd check for the latest firmware anyway...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.