Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 3 machines (A, B and C) behind WLAN Router. From B i can make ssh to A and from A to B also. Ssh between C and A is also working (both destination, C->A and A->C). But when i try to connect B to C or C to B i get always

ssh: connect to host <HOST> port 22: No route to host

What can be the reason for this error?

edit: I've made small mistake - machine A has wired connection to the router!

@ Marnix A. van Ammers: Here the three ifconfig outputs:

Machine A:

$ ifconfig eth0
eth0      Link encap:Ethernet  HWaddr XX:XX:XX:XX:74:b8  
          inet addr:192.168.0.9  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::211:95ff:fe1c:74b8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4602075 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8746230 errors:0 dropped:0 overruns:13 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:816857533 (816.8 MB)  TX bytes:2974068829 (2.9 GB)
          Interrupt:11 Base address:0x1800 

Machine B:

$ ifconfig wlan0
wlan0     Link encap:Ethernet  Hardware Adresse XX:XX:XX:XX:f8:7a  
          inet Adresse:192.168.0.5  Bcast:192.168.0.255  Maske:255.255.255.0
          inet6-Adresse: fe80::21b:77ff:feb6:f87a/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:39449 errors:0 dropped:0 overruns:0 frame:0
          TX packets:36805 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX bytes:28118658 (28.1 MB)  TX bytes:5681482 (5.6 MB)

Machine C:

$ ifconfig wlan0
wlan0     Link encap:Ethernet  Hardware Adresse XX:XX:XX:XX:a7:b5 
          inet Adresse:192.168.0.8  Bcast:192.168.0.255  Maske:255.255.255.0
          inet6-Adresse: fe80::226:b6ff:fe4e:a7b5/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:35 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:1611 (1.6 KB)  TX bytes:5613 (5.6 KB)

The netstat outputs:

Machine A:

$ netstat -nr
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
192.168.0.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
0.0.0.0         192.168.0.1     0.0.0.0         UG        0 0          0 eth0

Machine B:

$ netstat -nr
Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags   MSS Fenster irtt Iface
192.168.0.0     0.0.0.0         255.255.255.0   U         0 0          0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 wlan0
0.0.0.0         192.168.0.1     0.0.0.0         UG        0 0          0 wlan0

Machine C:

$ netstat -nr
Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags   MSS Fenster irtt Iface
192.168.0.0     0.0.0.0         255.255.255.0   U         0 0          0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 wlan0
0.0.0.0         192.168.0.1     0.0.0.0         UG        0 0          0 wlan0
share|improve this question
    
Can you show us the IP addresses and netmask settings for each host and output of 'netstat -nr' in each host? –  Marnix A. van Ammers Apr 29 '10 at 18:09

3 Answers 3

up vote 3 down vote accepted

It seems likely that multicast is not working reliably on your wireless network, and that's breaking ARP. Look at your ARP tables on B and C to see if either host is missing an ARP mapping for the other. Try adding it manually and see if the problem goes away. Then you can troubleshoot your wireless network's multicast problems later.

share|improve this answer
    
It seems, that B can see only A and the router, but not the C. C also access only A and the router. I'll try to add it and will give you a feedback. –  cupakob May 1 '10 at 10:19
    
It works, after I've added B in C and C in B. Can you tell me, how to make this change permanently (OS is Ubuntu)? –  cupakob May 1 '10 at 11:17
    
Adding static ARP mappings is just a workaround for this one situation. Broken multicast on your network is the real problem, and it will break other protocols in strange ways unless you address that. –  Spiff May 1 '10 at 22:20
    
i found a solution - some router settings caused the problem ;) thanks a lot... –  cupakob May 2 '10 at 9:34
    
Don't forget to share what the exact solution was, so that others in this situation can find the solution. –  Spiff May 2 '10 at 15:27

As original poster didn't explain what "router settings caused the problem", I do it:

Some wireless routers have settings to keep stations connected wirelessly isolated.

Let's take TP-LINK TL-WR740N (V1 or V2) as an example.

On the "Wireless Advanced" page of the web-based management that model has checkbox "Enable AP Isolation" explained as:

Enable AP Isolation - Isolate all connected wireless stations so that wireless stations cannot access each other through WLAN.

share|improve this answer
    
Thanks @dad it helped me :) –  Jeshwanth Kumar N K Dec 3 '13 at 18:31

Check the network settings for machine C.

If you are using DHCP (dynamically assigned IP addresses) for machines A and B, then you probably want to configure machine C to use DHCP also.

If you are using static IP addressing, make sure that machine C has a proper IP address (most likely, this means an IP address on the same subnet as machine A and machine B, since you haven't mentioned any other complexities in your network).

share|improve this answer
    
A, B and C are using DHCP. –  cupakob May 1 '10 at 10:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.