Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been using MSE for a couple months now, never had a single problem. All of a sudden the process "MsMpEng.exe" will randomly go crazy and hog all my system resources so I can't do anything unless I kill it in the task manager. (I've quit the program for now and my comp is running smooth). When I restart the program, reboot, whatever, it goes off and hogs all the resources again after a couple minutes. If I kill the process it will go away and then come back a couple minutes later and do the same thing. I've scanned with MSE, another antivirus and malware with no probs. Any ideas? Should I uninstall and find something else? The thing is I've liked it so far. I'm running Win7 64-bit.

Also, I'm not running any other conflicting security programs. This is the only one on my PC right now. Windows Defender is also off.

share|improve this question
    
What resources are you talking about? CPU/Memory/IO/...? –  Tom Wijsman Feb 12 '11 at 23:34

2 Answers 2

You can adjust the amount of resources MSE uses. The following settings can decrease the resources usage without greatly effecting the effectiveness of MSE.

  • look at the settings tab>"scheduled scan" settings in MSE you should see the option to limit the cpu usage from 10-100%.
  • look at the "real time protection" settings and see what effect unchecking "enable network inspection system" and "enable behavior monitoring"
  • look in the "advanced" settings and see if "scan archive files" or "scan removable drives" are enabled.
  • verify your install is fully updated
share|improve this answer
    
+1 Didn't know that MSE allows you to limit CPU usage, nice! –  Tom Wijsman Feb 12 '11 at 23:33
    
Pretty sure the culprit was the behavior monitoring option. As soon as I disabled it and saved settings, CPU usage dropped considerably. –  Christopher Parker Jul 14 '11 at 14:43

Not the ideal solution, but you can attempt to set the process affinity to a single processor core so it can't take all the resources. This should leave your other processor core to do the other tasks you need.

This only works if you have a Multi-Core CPU obviously. :)

http://www.addictivetips.com/windows-tips/how-to-set-processor-affinity-to-an-application-in-windows/

share|improve this answer
    
This hogs a complete core, and will bother programs that use multiple cores. It might be more than just CPU. –  Tom Wijsman Feb 12 '11 at 23:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.