Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to change resolution in ubuntu 10.04 ( as I am used to do in earlier versions) but It didn't works for me!

I want to change the resolution to be 1024x768 (that doesn't appear by default in System>Preferences>Display)!! please help

share|improve this question

migrated from serverfault.com Apr 30 '10 at 8:34

This question came from our site for system and network administrators.

2 Answers 2

up vote 5 down vote accepted

Actually, the solution was the following:

Section "Device"
    Identifier  "Configured Video Device"
    Driver      "vesa"
EndSection

Section "Monitor"
    Identifier "Generic Monitor"
    Option "DPMS"
    HorizSync 27-149
    VertRefresh 43-172
EndSection

Section "Screen"
    Identifier "Default Screen"
    Device "Generic Video Card"
    Monitor "Generic Monitor"
    DefaultDepth 24
        SubSection "Display"
        Depth 24
        Modes "1280x800" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection
share|improve this answer
1  
could you mention where to apply that solution? what file does that go in? is it /etc/X11/xorg.conf ? –  JustJeff Jul 18 '10 at 12:55
    
Ya, If you haven't one, create one, X11 still can read it if you create one in /etc/X11 –  Muhammad Hewedy Jul 30 '10 at 12:04
  1. Start Virtual box and log into Ubuntu.

  2. Hit the right ctrl key so you can get your mouse pointer outside the virtual machine.

3.Go to top of virtual window, click on devices then select "Install Guest Additions" You will see a window pop up inside Ubuntu showing you that there are some new files mounted in a virtual CDROM drive. One of those files should be VBoxLinuxAdditions.run

You must run the file with some admin permissions so do that this way...

  1. Click inside the Ubuntu screen again then go to Applications - Accessories then Terminal. The terminal window is where you will run the file from, but first we must navigate to the correct directory.

  2. type this... cd /media/cdrom0 (then hit enter, there is a space after cd!)

  3. next type... dir (You should see amongst the files displayed VBoxLinuxAdditions.run)

  4. now type... sudo sh ./VBoxLinuxAdditions.run (yes, that is a full stop before the slash!)

after you hit enter and it has done its stuff, the files are now accessable from Ubuntu.

  1. You now need to reboot the virtual machine or press Ctrl+Alt+backspace.

  2. Log onto the Ubuntu desktop and this time go to System - Preferences then Screen Resolution. You should now have more options than the three low res options you had at the beginning of the day!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.