Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a mac laptop running XP inside VirtualBox. The network is setup to be a "Bridged Adapter" so that the IPs for both the host & guest OS's are assigned by my wireless routed.

My guest XP has Nortel VPN connecting to corporate lan. When this is connected, I want to allow my host Mac OS to access the corporate network. But I'm struggling.

Without Nortel VPN running, I can change routing on the mac so all traffic is sent via the guest XP - this works. But once I activate the VPN, this no longer works. If I try to change the routing on mac to run through the IP address assigned to the Nortel adapter, I get a "Network is unreachable" error.

Below is the output from ipconfig /all on the guest XP OS.

I'm beginning to believe that what I want to do is not possible because of the way Nortel secure the VPN - but before I give up I thought I'd post the problem here.

Thanks, Kevin

z:\eclipseworkspace\RESMobileSuite\trunk>ipconfig /all

Windows IP Configuration

    Host Name . . . . . . . . . . . . : zzzz-3177b42dd0
    Primary Dns Suffix  . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : Yes
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : zzzz.zzz

 Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix  . :
    Description . . . . . . . . . . . : AMD PCNET Family PCI Ethernet Adapter
    Physical Address. . . . . . . . . : 08-00-XX-XX-XX-XX
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.1.3
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DNS Servers . . . . . . . . . . . : 192.168.1.1
    Lease Obtained. . . . . . . . . . : 30 April 2010 12:22:02
    Lease Expires . . . . . . . . . . : 01 May 2010 12:22:02

    Ethernet adapter {8EB7A442-9683-45FB-A602-56110A4B3434}:

    Connection-specific DNS Suffix  . : zzzz.zz
    Description . . . . . . . . . . . : Nortel IPSECSHM Adapter - Packet Scheduler Miniport

    Physical Address. . . . . . . . . : 44-45-YY-YY-YY-YY
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : XXX.4.52.62
    Subnet Mask . . . . . . . . . . . : 255.255.254.0
    Default Gateway . . . . . . . . . : XXX.4.52.62
    DNS Servers . . . . . . . . . . . : XXX.6.21.36
                                        XXX.6.21.100
share|improve this question

1 Answer 1

Try this:

  1. Enable connection sharing on Windows XP interface
  2. Add routing table entry on your MAC for your company network. I don't know Mac but it probably would be something along these lines:

    route add XXX.4.52.62 mask 255.255.254.0 192.168.1.3

share|improve this answer
    
Hi Kyrisu - as I understand things, to enable connection sharing on XP, I need to select two connections (displayed in the Network Connections list) and bridge them. The problem is that I only see the AMD ethernet adapter, not the Nortel adapter in this list. –  Kevin Apr 30 '10 at 12:40
    
I meant Right click on the connection -> Properties -> Sharing Tab , but maybe even better would be to enable routing home-network-help.com/ip-forwarding.html –  kyrisu Apr 30 '10 at 20:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.