Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
I tried installing Ubuntu 10.04 and I got this message - any ideas on what to do?

No root file system defined. Please correct this from the partition menu.

This message shows up when I first boot into Ubuntu after the installation.

I installed it by mounting the ISO with Daemon Tools, and I just did the default Wubi installation. I keep reading everywhere that I need to choose my installation directory, but I don't get any option to do that. These are all the options I get for installation directory:

enter image description here

I have a C and D partition on my drive, and I tried installing it on both and no luck either way.

Any ideas?

share|improve this question

migrated from stackoverflow.com Apr 30 '10 at 17:47

This question came from our site for professional and enthusiast programmers.

marked as duplicate by studiohack Aug 31 '11 at 18:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
Welcome to Linux :) –  BlueRaja Apr 30 '10 at 17:46
1  
Sorry, I know that is not an answer to your question, and maybe you've already walked along this path but...why don't you try Lucid Lynx within VirtualBox or VMWare? –  dag729 Apr 30 '10 at 17:53
add comment

3 Answers

Seems there a bug which messes with multiple boot systems.

phoronix.com/

From lifehacker- the-best-improvements-in-ubuntu-1004-lucid-lynx:

boot options for non-Ubuntu partitions can stop working. The fix is to run sudo update-grub from a terminal, or after hitting Alt+F2 for a prompt, and Ubuntu is working on "re-spinning" the ISO images that are affected.

share|improve this answer
add comment

The Wubi installer might have installed Ubuntu as a program within Windows instead. If that isn't what you intended, then you might need to "uninstall" Ubuntu from Add/Remove Programs, and follow the steps provided in this Lifehacker article.

Disclaimer: I'm an Ubuntu/Linux newbie. I'm also waiting for more experienced users to pitch in with their ideas as well.

share|improve this answer
add comment

I don't have any experience with wubi, but definitely sounds like a bug here. The problem here is of linux is unable to find and mount the filesystem! As per the wubi documentation, it should mount c:\ubuntu\disks\root.disk (or D or whatever drive you opt for) as the root filesystem. But in your case this is failing.

Maybe you could check if the file exists? More then that I can't help you.

If I may, I would suggest to install Ubuntu on a separate partition instead of going through wubi. Wubi will generally will be slow.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.