Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using empathy in Ubuntu 10.04 (64 bit), everything worked great after initial setup. But after disconnecting and reconnecting, any Jabber connection (GTalk and Facebook Chat) gives a 'network error'.

Tried disabling accounts and only connecting to GTalk, same error. Tried removing all accounts, adding GTalk, same error. Upgraded to the dev version of Empathy, connected once, then after going 'offline' and reconnecting, same error.

If it just didn't work, I'd wait for some kind of fix. But it did work, but only once per install. How does that happen?

Anyone with this problem that solved it?

share|improve this question
add comment

1 Answer

This solved the problem for me:

  1. Disable the accounts in Empathy (F4).

  2. Go to seahorse (applications > accessories).

  3. Select the password tab > remove the passwords for the accounts in question.

  4. Enable the accounts back and re-enter the password in Empathy (F4)

The "network error" in my case was not a connection error (the accounts where working in my other jabber client "Psi") but a glitch in seahorse. Empathy relies on seahorse to store the account passwords.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.