Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'd like to first say ahead of time that I'm running a RAID-0 Setup.

1.First of all, I'm glad Ubuntu 9.10 installed flawlessly and detected my RAID-0 setup just fine. The issue I'm having now is that I already had Windows 7 installed and made a small 12GB partition for Linux/Swap.

I grabbed EasyBCD 2.0 to edit the W7 bootloader and configured it to use dual boot Grub2 because before it didn't even show the option for Ubuntu. The bootloader points to a file made in the windows directory made by EasyBCD called C:\NST\AutoNeoGrub0.mbr which is what I'm guessing grub is booting from.

After that I got the option for booting Ubuntu. The problem is that it's sending me to the Grub prompt (probably because it's pointing to \NST|AutoNeoGrub0.mbr?), at first I didn't know what to do but I researched and have to type grub commands to manually boot into Ubuntu Linux.


grub>root (hd0,4)

grub>kernel /boot/vmlinuz-2.6... root=/dev/disk/by-uuid/24624-2424...

grub>initrd boot/initrd.img-2.6...


After all that Ubuntu boots just fine, but how do I fix it permanently? Do I need to edit the bootloader manually (since Easy BCD "autoconfigures")? Some insight on this would rock!

Also, it sucks to type the actual uuid since it's REALLY long. I tried getting the name of the drive via fdisk -l but since it's raid 0 I'm guessing I can't do that. How can I get a shorter name of the drive? like /dev/sda, /dev/sdb etc?

I've also tried to update to the latest GRUB and I got this:

Creating config file /etc/default/grub with new version  
Generating core.img  
error: cannot seek `/dev/sdc'  
error: cannot seek `/dev/sdc'  
grub-probe: error: no mapping exists for `nvidia_dbedfcca5'  
Auto-detection of a filesystem module failed.  
Please specify the module with the option `--modules' explicitly.  
dpkg: error processing grub-pc (--configure):  
subprocess installed post-installation script returned error exit status 1  
dpkg: dependency problems prevent configuration of grub2:  
grub2 depends on grub-pc; however:  
Package grub-pc is not configured yet.  
dpkg: error processing grub2 (--configure):  
dependency problems - leaving unconfigured  
No apport report written because the error message indicates its a followup error from a previous failure.  
E: Sub-process /usr/bin/dpkg returned an error code (1)   

I've also tried:

b@dnb:~$ sudo update-grub  
error: cannot seek `/dev/sdc'  
error: cannot seek `/dev/sdc'  
Generating grub.cfg ...  
Found linux image: /boot/vmlinuz-2.6.31-14-generic  
Found initrd image: /boot/initrd.img-2.6.31-14-generic  
error: cannot seek `/dev/sdc'  
grub-probe: error: no mapping exists for `nvidia_dbedfcca5'  
error: cannot seek `/dev/sdc'  
grub-probe: error: no mapping exists for `nvidia_dbedfcca5'  
Found memtest86+ image: /boot/memtest86+.bin  
Found Windows 7 (loader) on /dev/mapper/nvidia_dbedfcca1  
error: cannot seek `/dev/sdc'  
grub-probe: error: no mapping exists for `nvidia_dbedfcca1'  

To no avail. Any idea what I can do to fix this mess? :(

Edit: This is my disk configuration.

b@dnb:~$ sudo df -l  
Filesystem           1K-blocks      Used Available Use% Mounted on  
                      12302232   2744788   8932520  24% /  
udev                   1030288       268   1030020   1% /dev  
none                   1030288       964   1029324   1% /dev/shm  
none                   1030288        92   1030196   1% /var/run  
none                   1030288         0   1030288   0% /var/lock  
none                   1030288         0   1030288   0% /lib/init/rw  
/dev/sr0                706532    706532         0 100% /media/cdrom0  

Note: /dev/mapper/nvidia_dbedfcca5 is my Linux boot partition

share|improve this question
up vote 2 down vote accepted

I found the answer in case of anyone out there that stumbles into the same problem. Installing EasyBCD 2.0 while using the GRUB2 Option on linux fixes the issue where Linux doesn't appear as an option.

As far as the solution for my problem all I had to do was switch to lucid repository, reinstall grub2 and switch back to karmic. Had to dig through tons of answers and tried so many options and these are the steps that worked.

Open terminal, type:

sudo gedit /etc/apt/sources.list

change the word karmic to lucid and save afterwards

close terminal and gedit

Next, go to:

System > Administration > Synaptic Package Manager

Search for grub2, grub-pc, grub-common and "remove completely"

open terminal

sudo apt-get install grub2

after it's finished reboot and it's done!

(Don't forget to change Lucid to Karmic again once you reboot)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .