Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

May I know how I can get rid of the Window Animation (seen when you minimise or maximise a window) in Windows XP Service Pack 3 Permanently‎?

I have tried the following two solutions:

  1. I went to the control panel, adjust visual effects, then unchecked the "Animate windows when maximising and minimising" option
  2. I have tried using windows powertoys tweakUI to disable the animation.
  3. I even tried Turn Off Window Animation
    • You can shut off the animation displayed when you minimize and maximize Windows
      • Open RegEdit
      • Go to HKEY_CURRENT_USER\Control panel \Desktop\ WindowMetrics
      • Create a new string value "MinAnimate".
      • Set the value data of 0 for Off or 1 for On
    • But still no help.

The Big Problem is that the window animation will disappear for a while but returns again some time later. When I navigate back to the "adjust visual effects" window, the checkbox for "Animate windows when maximising and minimising" is checked again.

Thank you very much

share|improve this question
add comment

2 Answers

There is a reference to TweakUI on this XPAnnoyances site.

Here is another reference you might like: 10 Steps to a Faster Windows XP.
Step 9 again refers TweakUI to disable animation.

TweakUI does a registry tweak which you will also find around.
You need to add a MinAnimate string with a zero value in,
HKCU/.default/Control Panel/Desktop/WindowMetrics, I think.


Update:
after reformatting your question, I could read it better

  1. Have you confirmed administrative rights for the user you login as?
  2. You are changing the HKCU key for your user identity,
    Try the HKU default path from my answer above.
  3. And, it is suggested that you reboot after the edit -- did you do that?
share|improve this answer
    
Thanks nik. I cannot find the button to add comments to your answers. Sorry about that. Yes. My account is the only account and it is that of an administrator. I will update you again if your solution works. –  epale85 Feb 9 '11 at 3:59
add comment

In [HKEY_USERS\.DEFAULT\Control Panel\Desktop\WindowMetrics] add or update the following registry key :

"MinAnimate"="0"

MinAnimate is a REG_SZ

Reboot immediatly.

Be careful : it is in HKEY_USERS not in HKEY_CURRENT_USER.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.