Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Earlier today I tried upgrading my Ubuntu 9.10 Karmic Kaola from the update manager. (FYI: all 9.10 updates were applied prior to this) Everything was going well downloading until I got an error dialog informing me that some software packages weren't downloaded because of an Internet connection. Would say it was halfway thru. Anyway, Was told that the software packages that it did download, however, would kept and I figure it's not a big deal. Just run it again.

But first ran Firefox to verify my connection as I haven't had any connection problems. But my internet connection was/is fine as evident by this posting. With that cleared, I ran the update manager again, clicked on "Upgrade" and this time I received "Could not download the release notes. Please check your internet connection"

This is my first time dealing with Ubuntu and my first upgrade so I am hoping someone can help. Not sure what the problem can be. I can surf the web with no problems.

PS: There was no installing at any point. Just downloading. PSS: The software it managed to download the first time around is now visible in the update manager but don't think I should install as I see in the compiz description it's for v1:0.8-4-0ubuntu2 I figure it's designed for 10.04 and might ruin things further if I install.

share|improve this question
up vote 2 down vote accepted

I had this problem, and it is now going through OK. I think the servers are being overloaded. Try it now, and if it still does not work, wait a bit and try again.

share|improve this answer
This is the main reason I download the ISO via bit torrent and install fresh :D – Tom May 1 '10 at 17:13
Makes sense. Attempted once more at noon & worked just fine. Perhaps I panicked too quickly last night. Gave me a good scare though. Thanks guys. btw, would download the ISO but I don't want to waste CD/DVDs – damx May 1 '10 at 19:44

Maybe the servers are overloaded, with everyone who is updating?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.