Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a some what strange problem (which could have an easy and obvious solution for all I know).

My problem is that when I've booted ubuntu (now 10.4 but same problem with 9.10) and turns it off it starts sending a HUGE amount of data via the ethernet cable, so much in fact that my router can't handle it and stops responding.

As far as I can tell the computer is completely turned off with no fans spinning. I can add that if I boot windows I do not have this problem, just when exiting ubuntu.

There are two "fixes" for my problem:

  • Pull the ethernet cable until the next boot
  • Turn off power to the PSU and wait for the capacitors to unload

Is there anyone who knows what could be going on? I'd be happy to post some logs or conf-files.

Currently I'm using the ethernet port on my motherboard which is a Asus P6T Deluxe V2 with an updated version of the BIOS (maybe not the latest but since it only happens when I've been in ubuntu I don't wanna mess with the BIOS too much).

Regards Nicklas

---------Update 1----------

The router is a D-Link DIR 655 with the latest firmware.

---------Update 2----------

I've now reinstalled ubuntu (with 10.4) and I still experience the same problem.

---------Update 3----------

Well I still haven't found a solution to this problem :(

share|improve this question
1  
Do you have another computer you can plug your Ubuntu machine into? I would directly cable the 2 computers together (using a crossover cable if you have one, but if your NICs are smart it might work with a regular Ethernet cable) and run Wireshark on the second one to capture what is being sent. Without that data its hard to say what is causing the problem. –  heavyd May 21 '10 at 15:08
add comment

migrated from stackoverflow.com May 1 '10 at 8:27

This question came from our site for professional and enthusiast programmers.

5 Answers

up vote 1 down vote accepted

I opened a topic in Ubuntu forums, and with their help, I made an workaround, that is working nicely so far. Check Topic here: http://ubuntuforums.org/showthread.php?p=9617739

share|improve this answer
    
Hey you should file a bug report at launchpad.net, so that the fix will get rolled into future ubuntu releases. –  intuited Jul 25 '10 at 3:12
    
That worked like a charm, thanks! –  Nicklas Ansman Jul 26 '10 at 11:11
add comment

What is indicating that your Ubuntu-shutting-down computer is sending data to your router?
I mean, do you have any other things to show that there was data being sent?
(for example, you might put a hub in the path and capture data on it while the shutdown is in progress... does that show such transfers?)

A simpler reason could be a driver malfunction causing the router to crash/stall.

Towards that end, it might help to publish your router specs too.


Update on your comment:

  • I am a little surprised with your problem. Do you by any-chance have a Wake-up-on-LAN configuration enabled in your PC-BIOS?

  • If you want to capture data between the router and the PC you will need another piece of hardware called a Hub which lets you 'tap' the wire between the PC and the Router (3 ethernet wires: 1 from PC, 1 from Router and a 3rd to a different PC capturing packets). Alternatively, if your router has more Ethernet ports and supports 'port-mirroring' you can pickup captures with that setup.

share|improve this answer
    
Well, I don't really know it's data all I know is that the router's activity LED for that channel is blinking like crazy. The router is a D-Link DIR 655 with the latest FW. Do you have any tips on how to capture the data to see? –  Nicklas Ansman May 1 '10 at 11:44
    
Yeah I know, it's weird. I've thought about wake on lan but it should only work the other way around I think. Will check my bios though. I don't have a hub only switches and since my router crashes I can't really use that :) I do however a bunch of other computers at home, I should be able to directly hook up two computers but I need some software to capture it, any suggestions? –  Nicklas Ansman May 1 '10 at 11:57
    
I went into my BIOS and I did not find wake on LAN. –  Nicklas Ansman May 1 '10 at 14:17
add comment

I have the EXACT SAME PROBLEM! In fact, I just discovered it because my router freezes.

I tried capturing with wireshark and tcpdump, directly connecting two computers. The other ethernet shows that it's receiving constant 192k but they capture nothing (must be faulty packets)

The only workaround so far is turning off PSU and turning it again.

share|improve this answer
    
Well that sound really similar, I cannot get wireshark to pick something up as well. –  Nicklas Ansman Jul 21 '10 at 20:49
add comment

Here are my troubleshooting steps:

  • Plug a network cable from the router and into my laptop and run Wireshark and see packets its sending out
  • Try a different router. No offense, many residential routers suck and/or are buggy (and they do this on purpose...but we won't discuss those semantics here ;))
  • Perhaps try plugging into a dumb switch w/o the router and see if there is activity, if there is then there is something wrong with your computer - if not its the router
  • If there is no activity in the dumb switch after powering down, then plug in the router to see if it makes your computer go crazy. If not, then I would say that port in the router is bad
  • Try another ethernet port in the router, on my Linksys WRT54GL, one of the ports actually went bad and makes my DSL modem go crazy
  • Buy a ethernet card and see if the problem persists
share|improve this answer
    
I tried to hook it up to my switch and it told me the same thing (LED kept flashing) When I tried sniffing with Wireshark it said that all that is being sent is a few DHCP-requests and some UPD-requests on port 17500 but not nearly as many as my routers says. In 5 minutes I got 43 packages. The weird part is this never happened before I installed ubuntu, I'm gonna attempt to make a clean install to see what happens. –  Nicklas Ansman May 1 '10 at 14:41
1  
@Nick I'm going to make a wild guess and say that Ubuntu's network driver doesn't properly shutdown the card. This leaves it in an invalid state when powered off causing it to do who knows what. I have no idea how to fix such a thing though –  Earlz May 7 '10 at 21:11
    
@Earlz That's what I've been thinking as well, kinda hard to debug seeing as my laptop did not register any actual data being sent. –  Nicklas Ansman May 8 '10 at 10:30
add comment

It could be a faulty Ethernet cable that sends out noise as the signal is coming down. Try a different cable.

share|improve this answer
    
But could this really explain why it's only when shutting down from ubuntu it's happing? –  Nicklas Ansman May 7 '10 at 22:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.