Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just installed ubuntu 10.4 but when i open Firefox it takes lon timeto open and also the sites are runnning very slow. when i click hyperink , it takes long time toopen

But the internet and FF is going at very good spedd in thevirtual machine which is inside the ubuntu with window 2008

what can be the reason

Any firewall issue

share|improve this question

2 Answers 2

up vote 0 down vote accepted

You can remove the firewall with: sudo apt-get remove --purge ufw

(Didn't find any point in using UFW, you can still use iptables (its a wrapper anyway)).

Also, you can try disabling barriers. Its a mount option for ext4. Will make it much faster, but if you encounter a power outage or something, you may lose data. So think. (To be honest I use it with that , I had some power loss, etc, no file loss at all). But I warned you. :)

So. Open /etc/fstab. sudo nano -w /etc/fstab
And search for the "defaults". Change it to noatime,barrier=0 . Save the file and exit (ctrl+x, y).

There is also an another entry with "remount" in that field (where the other had 'default'). Write it like you put a comma and write the noatime stuff behind. Like this:
errors=remount-ro,noatime,barrier=0 (not sure if the 'errors=remount-ro' is the one what you'll have, just check it.)

ASK if you dont understand something, ASK if something is not like I wrote. :)

About the net speed. Check /etc/resolv.conf >> sudo nano -w /etc/resolv.conf . Type in the OpenDNS addresses:
nameserver 208.67.222.222
nameserver 208.67.220.220 . Save the file, exit.

ALWAYS BACKUP THE ORIGINAL FILES! You can do that with nautilus (just copy the originals into your home) OR with sudo cp /etc/fstab /etc/fstab.old .

share|improve this answer
1  
If something goes FUBAR, you can use the LiveCD. Mount the partition with mount /dev/sda1 /mnt/ (we presume that 'sda1' is the current root partition of yours), and just cp back the old config files. –  Shiki May 1 '10 at 13:34

Is it possible that the Ubuntu machine has IPV6 configured, and the slow down is it trying everything on IPv6 first?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.