Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can connect to other computers on my home network (ubuntu + OSX machines) using the IP address, but I can't connect using the netbios name.

On the mac the name appears in Finder but if I try to connect (go>connect to server> smb://user@mythtv.local) it doesn't work, while smb://username@192.168.0.3 does. Same with ssh, ping and afp between the macs.

This is a intermittent problem. It has worked in the past.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Are you sure the device is using Netbios resolution? On the Mac, .local names are reserved for Bonjour resolution. Do you have an option to change the MythTV network name to something other than .local? Are both devices set to use the same Workgroup name (check the WINS tab in your Mac's Network Pane fort this setting)?

share|improve this answer

Are some of your machines connected wirelessly? If so, then you might have a bug where multicast isn't working reliably on some machines, breaking multicast protocols like Bonjour, and broadcast protocols like NetBIOS name service.

Make sure your multicast rate isn't set too high on your 802.11 Access Point. It has to be at a "lowest common denominator" rate; a rate low enough that all clients can receive it reliably no matter how far they are from the AP.

Also, try this test: temporarily turn off wireless security and see if the problem goes away. If it does, that's a good sign that either or AP or one or more of your clients isn't doing 802.11 multicast encryption correctly. Sometimes you can resolve this by switching from a more complex wireless security mode to a simpler one. For instance, WPA2 "Mixed Mode", where both AES-CCMP and TKIP encryption are enabled, is more complex because the multicast cipher type can be different from the unicast cipher type. Switching to pure WPA2 (AES-CCMP only) is simpler because it uses the same cipher everywhere, and as a bonus, it's more secure.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.