Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just installed Ubuntu for the first time using VMWare on Windows 7. Everything has been installed smoothly but after the installation, the login screen username prompt appears. When I try to enter password it does not accept any input, as if the keyboard is not working at all. After moving away from Ubuntu keyboard and everthing else is working fine. Does anyone know what's the cause behind this ?

share|improve this question

migrated from May 2 '10 at 12:50

This question came from our site for professional and enthusiast programmers.

There are alternatives to vmware, you might want to try virtualbox instead. – geek May 2 '10 at 18:02
I know it doesn’t have anything to do, but I have both VMware and Parallels and my Ubuntu 9 got seamlessly upgraded to 10.4 this morning. I had to “upgrade” the Parallels tools but that was it. I’ve lost Desktop effects tho’. – Martín Marconcini May 3 '10 at 12:14
You should change the title to say "Ubuntu 10.4 doesn't accept keyboard input at the login screen in VMware" -- seems to only affect the login screen. – matthews May 6 '10 at 20:54

Try Martin Pitt's solution. Worked fine for me. This was found @ but to save you the time from reading, below are the quick steps to get it working.

sudo add-apt-repository ppa:pitti/sru-test

sudo apt-get update

sudo apt-get upgrade

share|improve this answer
This is for Jim since I can't comment yet. The OP stated he can login using the Ubuntu keyboard, then his keyboard works fine after the desktop appears. I too had the same issue, and this is what fixed it for me. – Jesse May 5 '10 at 18:14
Use the virtual keyboard to login -- click on the weird wheel thing in the bottom of the login screen. – matthews May 6 '10 at 13:02

If the keyboard isn't allowing input, how does one use the suggest command lines?

share|improve this answer
There's a virtual keyboard -- try clicking on the weird wheel on the bottom of the login screen. – matthews May 6 '10 at 20:53

I can't remember the last time I used Ubuntu on the desktop, but generally the "Linux thing" so to speak is not to show the little asterisks when you type a password. It's just a security thing so observers can't see how many characters you've typed.

I'm not sure that's what you're referring to, but it may be the case that your keyboard is indeed working and it's just that you're not used to the lack of visual feedback? If your keyboard works in one place it should work everywhere ;)

share|improve this answer
I guess it's an VMVare issue, since the dots are shown when logging in on Ubuntu. At least they did show up on my system a few hours ago :D – Ivo Wetzel May 2 '10 at 12:19
If VMware grabs the output, you get a message at the bottom. Look for that. (Or press ctrl+g for direct input). || Ivo: Only at graphical login. – Shiki May 2 '10 at 12:59
Mouse input is going in but at the login screen (and only the login screen) keyboard input isn't going through. – matthews May 6 '10 at 20:52

use putty and ssh into your machine. Let's hope sshd is running.

share|improve this answer

Same problem in Ubuntu10.4 64-bit beta or release. My work-around has been to turn on the on-screen keyboard that is part of Accessibility settings. It is available right on the login screen. Icon: look for icon that looks like human with arms open-wide(Star Trek) or Leonardo Da Vinci's human body proportions drawing (art class). One on-screen keyboard is checked I reboot and next time I go to log in the keyboard is there. I Click on my user id, I click on the password frame then use mouse to type out password. Once I'm logged in my regular keyboard works fine.

share|improve this answer
[Workaround] For affected machines, run: sudo dpkg-reconfigure console-setup Then do your settings - I had to do Dell PC 101 keys. all okay now, no need to use on-screen keyboard to login now. from web page – DMFlad May 10 '10 at 20:09

What worked for me was logging into Ubuntu from putty and installing the VMware client tools (before I could do this I had to make sure the appropriate Linux headers were installed, sudo apt-get install cpp gcc build-essential linux-headers-$(uname -r)).

BTW: I was upgrading---not installing a fresh copy.

share|improve this answer

Shutdown the Ubuntu Session and in the vmware player, click on your Ubuntu image then click edit Virtual Machine Settings. Click the options tab, Make sure General is highlighted in the left pane, then check the box that reads use enhanced virtual keyboard in the lower left corner. Should fix your problem.

share|improve this answer

You must log in to answer this question.

protected by Community Sep 4 '11 at 2:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?