Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have recently upgraded from karmic to lucid (plain ubuntu using gnome).

Everything worked fine, but the characters now aren't anti-aliased any more, as you can appreciate from the screenshot:

alt text

This is what I tried to fix the situation, unluckily without succeeding:

  1. Used the regular option pane from System->Preference->Appearance->Font (smoothing, hinting...)
  2. Edited the .fonts.conf file
  3. Disinstalling (and then re-installing) the mstcorefont package
  4. Changing the default Sans font to a font of my liking (e.g. Tahoma) from the abovementioned Appearance options

My ubuntu installation is quite standard, with the typical add-ons one might wish for usability. I used the ubuntu start script to make a few tweaks.

share|improve this question
    
Can not confirm, everything is still antialiased nicely after upgrade. I'm using Bitstream Vera Sans though. –  vava May 3 '10 at 17:20
    
@vava - It seems it has something to do with the font. I am now using a non-standard font and it does antialias correctly, but as soon as I switch to "sans" (which I do not know where points at) or "tahoma" the antialiasing gets messy... Any suggestion on how to refine the search is welcome. –  mac May 4 '10 at 12:54
    
When you edited .fonts.conf, did you try setting autohint to true? –  Juliano Aug 12 '10 at 14:02
    
Did you try the system's fonts.conf or just the one in your user's home directory? –  Just Jake Mar 29 '11 at 21:09

2 Answers 2

Try creating a new user, log in as the new user, and see whether the problem still exists. If not, something's wrong with your configuration under $HOME (which is common after a distribution upgrade). If it still exists, something is wrong with the system. You may need to sudo aptitude purge some packages (and reinstall them after that, of course) instead of just remove, which leaves system-wide configuration files untouched.

share|improve this answer
up vote 0 down vote accepted

I was never able to fix the problem with that release, but the new LTS 12.04 does not present the same problem any more.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.