Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Latitude D630 Laptop with a Fresh Windows XP install that won't work with a generic external USB mouse. It recognizes the device has been put in but fails to install it.

  • USB keyboards work fine
  • I have tried restarting the laptop
  • Tried starting the machine without the docking station and plugging directly into the laptop
  • Don't have the original CD, but I installed drives from the Dell website until there were no ? icons
  • Tried deleting the USB mouse device and plugging it again
share|improve this question
    
Did you test the mouse on a different machine? Does a different USB mouse work with the laptop? –  Velociraptors May 3 '10 at 15:02
    
No USB mouses seem to work. –  Kyle Brandt May 3 '10 at 15:48

2 Answers 2

I have seen this happen with a Logitech mouse. Worked perfectly on several systems but one Dell laptop would not install the device. I downloaded the Logitech driver and installed it and it then worked fine. No idea why.

Have you updated the MB driver package from the Dell site as well? It will be listed as a "Chipset" driver package for the Intel Mobile Chipset. That install has cured issues with MB devices as well

share|improve this answer
    
It is a dell mouse but came with another. Updated the chipset and security drivers. –  Kyle Brandt May 3 '10 at 15:48
    
I used Logitech drivers for Dell mouse and that worked. No idea why. Have you deleted any mouse related entries in Device manager? Be sure to Show Hiddden Devices (View-Show Hidden Devcices). Have seen mouse there with Exclamation mark. Remove and all is well. –  Dave M May 3 '10 at 16:05
    
You shouldn't have to install mouse drivers... –  James Watt May 3 '10 at 16:31
    
@James Watt As mentioned, installing resolved the issue for me. Understood that a generic mouse should just work. –  Dave M May 3 '10 at 16:45

Finally figured it out:

  1. I will find the bleeping driver myself
  2. Don't search, I know where it is
  3. It was already there in the list of drivers, but wasn't digitally signed so I am guessing the prevented Windows from using it. Once I selected it the mouse installed fine.
share|improve this answer
    
(If someone wants to format this a little better in their own answer I will delete mine, upvote theirs, and accept it. –  Kyle Brandt May 3 '10 at 16:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.