Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Ubuntu 10.04. It works fine, but when I press Ctrl-C in gnome-terminal I get:

user@desktop:~$ ^C
user@desktop:~$ ^C
user@desktop:~$

In Ubuntu 9.04 (I did have it before) it was so:

user@desktop:~$ 
user@desktop:~$ 
user@desktop:~$

Who knows how can I fix this?

share|improve this question
    
i expect, best case, this is due to an obscure bash (or possibly gconf) setting; medium case, this is due to some tweak in a terminfo file; worst case, you'll have to patch code and recompile your bash or gnome-terminal packages. – quack quixote May 3 '10 at 16:40
up vote 4 down vote accepted

Give this a try, it will affect other control characters, too:

stty -echoctl
share|improve this answer
1  
Dennis, thanks a lot. It works. But when I close gnome-terminal and run it again this parametr is on. How can I save it? – sev May 3 '10 at 18:26
    
@sev: Add that command to your ~/.bashrc file. – Dennis Williamson May 3 '10 at 19:26
    
You should make that only run when you're on a terminal, with something like: [ -t 1 ] && stty -echoctl – NVRAM May 4 '10 at 0:16
    
@NVRAM: I'm curious what the downside is. Besides, normally ~/.bashrc is only loaded for interactive shells. – Dennis Williamson May 4 '10 at 0:31
    
Hmm, I think you're right. If it's in ~/.bashrc rather than ~/.profile or ~/.bash_profile -- it would be good to add that to the answer. While it would probably not kill the job (just print an unneeded error) it's a habit I picked up using Bourne and K-shells -- to avoid interactive commands for when the profile was run by cron or at jobs. – NVRAM May 7 '10 at 15:44

you can also highlight and use right click on systems you access but don't want to or have time to change settings.

share|improve this answer

You just have to hold the Shift key down as well. So instead of just Ctrl + C, you do Shift + Ctrl + C.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .