Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a fresh install of Ubuntu 9.04 (jaunty) on my iMac (specifically iMac8,1, aluminum). In gnome-screensaver-preferences, I have the screensaver set to come on after 1 minute, and then in gnome-power-preferences, I have "put display to sleep when inactive for" set to 2 minutes. However, after 2 minutes, my screensaver keeps on running.

I'd like to know if anyone has a solution for how to get the iMac monitor in Ubuntu to automatically sleep, what packages I may need to download, or what the relevant log files would be to see if the event is getting trigger and/or what errors are coming up. If there isn't hardware support for sleeping an iMac monitor in Ubuntu, I'd appreciate that bit of info too.

EDIT: I'm not on the system right now, but I've found that the command "xset dpms force off" should force the monitor to sleep. If it works, then I need to figure out how to get the preferences to put the monitor to sleep. If not, it means I have a hardware issue to figure out. I'll update with more info when I get to try it.

share|improve this question
up vote 1 down vote accepted

It seems this was a documented bug that has been fixed. More information can be found at https://bugs.launchpad.net/ubuntu/+bug/363059. It cleared up the problem on my computer.

share|improve this answer

try this

xset dpms 0 0 120

after 120 sec. of inactivity, wil be the monitor put to sleep. I not realy shure if this will turn off your screensaver. If you wont to turn off it type

xset dpms 0 0 0

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .