Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Firefox 3.5.1 installed, but whatbrowser.org thinks that I'm using IE6 - as does twitter and youtube. I've reinstalled Firefox and disabled AddOns, but it is still registering as IE6. Any ideas?

share|improve this question
add comment

4 Answers

up vote 6 down vote accepted

Type "About:config" in the address bar, and check for a setting called "general.useragent.override." If it's there, delete it.

If it's not there, make sure you don't have a plugin like "useragentswitcher" or useragentbar" installed.

share|improve this answer
    
This fixed it - thank you! (now if I can only remember why I set that to begin with...) –  Kat May 5 '10 at 14:58
add comment

If you are at a school or work it could be the result of a proxy they are using.

share|improve this answer
add comment

Make sure you check the useragent. Sometimes, I've seen browsers that are IE 8, but have something in their UA that says something similar to, IE6 compatible, which the server treats as higher priority than the real browser.

share|improve this answer
add comment

There are good answers above: about:config useragent, any useragent switching plugins, and possibly a proxy.

You can try to debug this by checking your headers going out. Try LiveHeaders. Check the UserAgent in the request. If it's straight Mozilla, you have a proxy. If it's not (says IE (compatible Mozilla) or whatever, you have changed your settings.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.