Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Drupal site, which allows all logged in users to add and edit book pages. On the permissions page I have enabled they may also administer book outlines.

The problem is that they can do this for all nodes, even forum topics and pages, and blog entries. Does anyone know how I can fix this, so that people can only change this for book pages?

share|improve this question
    
Perhaps link the website? Since if I google Drupal I hardly understand your question –  Ivo Flipse Jul 27 '09 at 16:26
    
Sorry, my website is only on a local website. If you want to know what Drupal is, check drupal.org –  rightføld Jul 27 '09 at 16:27
    
Shouldn't this question be rather on serverfault? –  txwikinger Jul 27 '09 at 16:51

3 Answers 3

up vote 2 down vote accepted

You should look into the acl modules. There are acl modules that allow you a finer granularity which allows you to say certain users can only do certain tasks with nodes of a certain type.

share|improve this answer

Better, you can go to user management => permissions. from that, uncheck the relevant box in the authenticated users column. Instance "Administer nodes" (All Appropriate edit permissions). Similarly for your forum & blog modules.

share|improve this answer

In User Management -> Permissions be sure to uncheck the relevant boxes in the authenticated users column, for instance "administer nodes" (and all the appropriate edit permissions) under node module and similarly for your forum and blog modules.

share|improve this answer
    
Sorry, didn't help. They are unchecked already. –  rightføld Jul 27 '09 at 16:30
    
Hmm, only others things offhand I can think to check are (a) to make sure all the permissions set for authenticated users are correct and (b) that the users who are able to do this editing where they shouldn't be aren't accidentally set up with any role that they shouldn't have. And that you're not inadvertently logged in as admin while replicating this behavior, but rather logged in as an authorized user. –  Dan U. Jul 27 '09 at 16:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.