Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Mac OS X version is 10.5.8
Xcode 3.1.4

I hope to debug my app on the iPod Touch
iPod OS version 3.1.3(7E18)

Organizer told me that I need newest Xcode. I downloaded and try to install the newest Xcode, but it told me I need new Mac OS X.

So I clicked my Mac Mini's software update to check if there is new version.

It told me my softwares are newest.

I welcome any assistance.

share|improve this question
add comment

2 Answers 2

up vote 0 down vote accepted

Check that you have iPhone SDK 3.1.3. Xcode 3.1.4 paired with iPhone SDK 3.1.3 should work on your iPod Touch... That's all I can suggest. To check go into the Xcode menu -> Help ->more info (which opens system profiler) and in the development tab it should list all the iPhone SDKs you have. If 3.1.3 isn't already there download it. If you already have iPhone SDK 3.1.3... then... something's wrong.

If you want to redownload iPhone SDK 3.1.3 with Xcode 3.1.4, the download link is no longer "on the front page", but this developer.apple.com link http://developer.apple.com/iphone/download.action?path=/iphone/iphone_sdk_3.1.3__final/iphone_sdk_3.1.3_with_xcode_3.1.4_leopard_9m2809a.dmg should do. For other links to even older SDKs just look at the thread here.

Of course, when you find the time, it's probably recommended that you upgrade to Snow Leopard since Apple always loves the newest software. If you want to develop for anything past iPhone OS 3.1.3 Snow Leopard is a good investment.

share|improve this answer
    
there's a more pointed question about where to find it; the stackoverflow copy of the question has a better answer. –  quack quixote May 5 '10 at 0:27
    
Those are related to Xcode 3.0 I think... which isn't compatible with iPhone OS 3.1.3. –  Vervious May 5 '10 at 0:29
add comment

The newest XCode (3.2.2 I believe) is for Mac OS X 10.6 Snow Leopard. You are running OS X 10.5 Leopard. You need to upgrade to Snow Leopard ($29 USD) to be able to use the latest XCode.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.