Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I run Bugzilla's checksetup.pl (migrating an older version), and it always returns:

Reading ./localconfig. 
Checking for           DBD-mysql (v4.00)   Ok: found v4.005
Had to create DBD::mysql::dr::imp_data_size unexpectedly at /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/DBI.pm line 1229, <DATA> line 225.
Use of uninitialized value in subroutine entry at /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/DBI.pm line 1229, <DATA> line 225.
Had to create DBD::mysql::db::imp_data_size unexpectedly at /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/DBI.pm line 1259, <DATA> line 225.
Use of uninitialized value in subroutine entry at /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/DBI.pm line 1259, <DATA> line 225.
There was an error connecting to MySQL:

    Undefined subroutine &DBD::mysql::db::_login called at /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi/DBD/mysql.pm line 142, <DATA> line 225.

MySQL Version:

[root@bugzilla-core TMP]# mysql --version
Mysql  Ver 14.12 Distrib 5.0.60sp1, for redhat-linux-gnu (x86_64) using readline 5.1

And mysql_config:

[root@bugzilla-core TMP]# mysql_config
Usage: /data01/mysql-5.0.60/bin/mysql_config [OPTIONS]
Options:
        --cflags         [-I/data01/mysql-5.0.60/include  -g]
        --include        [-I/data01/mysql-5.0.60/include]
        --libs           [-rdynamic -L/data01/mysql-5.0.60/lib -lmysqlclient -lz -lcrypt -lnsl -lm -lmygcc]
        --libs_r         [-rdynamic -L/data01/mysql-5.0.60/lib -lmysqlclient_r -lz -lpthread -lcrypt -lnsl -lm -lpthread -lmygcc]
        --socket         [/tmp/mysql.sock]
        --port           [0]
        --version        [5.0.60sp1]
        --libmysqld-libs [-rdynamic -L/data01/mysql-5.0.60/lib -lmysqld -lz -lpthread -lcrypt -lnsl -lm -lpthread -lrt -lmygcc]

Now, I've tried the latest version of DBD-mysql (4.0.14). I'm completely lost and stumped. I'm not sure where to go from here. Scouring the 'webs haven't returned anything fruitful.

Any ideas?

share|improve this question

migrated from stackoverflow.com May 5 '10 at 1:56

This question came from our site for professional and enthusiast programmers.

2 Answers 2

there is a possibly related topic over at ServerFault. That said, this strikes me as possibly being a 32bit/64bit mix match problem - maybe a wrong RPM installed or something like that. Maybe try building dbd-mysql from source?

share|improve this answer

You must always build DBD::mysql against the version of MySQL you are using, on the platform you are on.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.