Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Telewell TW-EA510v4 ADSL modem+WLAN router configured as follows:

Mode: 802.11b+g Security Mode: WPA1 Pre-shared Key WPA Algorithms: TKIP

Connections from only certain MAC addresses have been allowed and the MAC address of my Mac is in that list. The WLAN works just fine with iPhone and an old Acer laptop.

It has worked for about two months or so with my MacBook Pro (year and a half or so old model). Ocassionally i've had minor problems with it, which have required either reboot of ADSL modem or reboot of my Mac. However now, for the last week or so I haven't been able to connect to it at all.

This is what is what i get in the console when i try to connect:

5.5.2010 20.54.53   airportd[73731] Apple80211Associate() failed -3924 (Invalid PMK)
5.5.2010 20.54.53   Apple80211 framework[584]   airportd MIG failed (Associate Event) = -3924 (Invalid PMK)  (port = 104599)
5.5.2010 20.54.53   SystemUIServer[584] Error joining WLAN-M: Invalid password (-3924 Invalid master key)

The pre-shared key I use is not incorrect. I'm 100% sure of that.

The Error Log from the router only says this when I try to connect to it:

May 05 21:09:54 home.gateway:i802_1x:none: <my mac address> associated
May 05 21:10:00 home.gateway:i802_1x:none: <my mac address> disassociated
May 05 21:10:01 home.gateway:i802_1x:none: <my mac address> disassociated

Any ideas or tips to troubleshoot this further?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

First, try deleting any entries in your keychain for that network. Check both your current account's login keychain as well as the system keychain. Also delete the entry for that network from your Preferred Networks list in System Preferences > Network > AirPort > Advanced > AirPort.

If that doesn't fix it, then assuming Snow Leopard, run:

sudo /usr/libexec/airportd debug +AllUserland +AllDriver +AllVendor

...then reproduce the problem and post the /var/log/system.log and /var/log/kernel.log from the time of the problem.

share|improve this answer
    
Thanks. Removed the network from my Preferred Networks and then deleted password for it from the keychain, that didn't work but after a reboot it works again. Curiosly the airport debug stuff didn't add anything to the logs that wasn't there before. –  Peto May 6 '10 at 17:35
    
Those commands don't persist across reboots. And most of their stuff will be added to the kernel log, not the system log or the console log. –  Spiff May 7 '10 at 22:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.