Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Are five letter filenames starting with "icon" illegal in SMB?

I just got a Drobo FS, in part to back up the computers in my house, and it does not accept folders named 'icons', 'iconv', or indeed I tried a bunch of other icon plus one letter names. I got errors on creation of these folders although now I don't remember the exact error.

It has been confirmed with Drobo support that they "veto" files and folders named like this, due to them being illegal in the SMB spec. My Google skills so far have not been sufficient to turning any information on this up, however, so I wonder if anyone knows what's up?

Sadly I can create these files and folders from my Mac, which I guess connects using AFP? But then I can't see them on my Windows machines. This is of little help if it is my Windows machines that I want to back up, and those being the ones with folders named like this.

Thanks.

Edit: I don't know how to retrieve useful information directly from Samba, as that's running on the box itself, but when I do 'mkdir icons' in Cygwin (1.7.1) I get "mkdir: cannot create directory 'icons': No such file or directory". Making a new folder in Explorer and changing 'New Folder' to 'icons' followed by yields a popup that says "Cannot rename New Folder: Cannot find the specified file. Make sure you specify the correct path and file name." Oddly there is more than one space between those last two words. Anyway- this popup has only an 'ok' button, and pressing that returns the folder name to 'New Folder'. Perhaps obviously, either of these operations with another name works fine.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I have an open ticket with Data Robotics about this too. Any five-letter file or folder name where the first four characters = 'icon' fails (icon9 fails, icon10 does not). They gave me the impression that engineering is working on a firmware fix.

I don't believe this is a Samba issue, because I'm trying to copy those 'icon?' files from another Samba/linux-based RAID, and it doesn't have problems with them. Much more likely a Drobo bug, I'd think.

share|improve this answer

I am using samba 3.3.2 and I can create files named iconv, icons, icon*

I think if you tell the exact error, we can just lookup in the samba code and let you know whether its a samba error or an underlying error on Drobo.

share|improve this answer
    
To be certain, you're creating those files from Windows Explorer? Is there any difference if you create directories instead? –  dash-tom-bang May 6 '10 at 0:13
    
Ok, dash-tom-bang. Confirming successfully creation of icon* folders from Windows Explorer (Windows XP SP 2). I think this is a problem with the holy-proprietary-software-cows. Have you tried creating the folder from a linux machine ? What is the error you get ? Also, what is the error in the server logs ? –  Knight Samar May 8 '10 at 13:41
    
Folders of these names can be created from OSX. Drobo support has verified that this is a "known issue" and they stand by the assertion that it's stated in the SMB spec that this is an illegal filename, but that hasn't stopped all other Samba installations from allowing it! Apparently the next firmware will remove this restriction with the caveat that I "may experience problems." Great, thanks guys. –  dash-tom-bang May 13 '10 at 0:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.