Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running ubuntu jaunty (really kubuntu, but it shouldn't matter) with firefox 3.0.12 and adobe's flash 10 plugin, and I often have the problem that firefox freezes while I'm playing hulu. The video freezes, but the sound keeps playing, and I can't navigate firefox (e.g. I can't close the window, so I have to kill it). This only happens when I'm playing full screen or in a stand-alone window (not in the small embedded video in the web page, but I haven't tested this extensively).

  1. Is this a common problem?
  2. Any ideas for how to fix it?
  3. Right now, I can't reproduce the problem on demand, and I don't really know which component of the system is misbehaving (ubuntu/firefox/plugin). Any ideas for how to figure out what's going wrong?
share|improve this question
2  
What video card are you using... I could see it being an issue with the driver. –  codeLes Jul 27 '09 at 17:43
    
Thanks codeLes. I'm a dummy for not thinking to check that. lspci tells me "VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)". Google shows me that other people have had problems with Intel 82G33/G31, but I haven't found a solution yet, and I'm not sure if those problems are the same as mine. I'll keep looking –  Anton Geraschenko Jul 27 '09 at 18:42

4 Answers 4

I'm not sure what's causing your problem, but I would try installing the latest flash player from the adobe site. I think they've fixed a few bugs since the version in the repositories.

share|improve this answer
    
Thanks DLH. I've just tried this, and I haven't yet been able to reproduce the problem yet. I'll have to see over the next couple of days if this took care of the issue for good. –  Anton Geraschenko Jul 27 '09 at 23:23
    
The problem persists. –  Anton Geraschenko Jul 28 '09 at 4:41
    
I'm sorry to hear that. I wish I could advise you better. –  DLH Jul 28 '09 at 14:50

I'm running Windows, but for the choppy full screen issue: right-click on the Flash video and deselect "enable hardware acceleration." What worked immediately for me.

share|improve this answer

Try disabling adblock, that worked out for me.

share|improve this answer

I have the same issue. Flash performance on ubuntu has been terrible for quite a while, though certain video cards seem worse off than others. I'm running an nvidia 6200. Full screen flash video is always choppy, and hulu stops precisely as you describe.

I'm sad to say after a couple months of trying every hint I can find, nothing has improved it.

It does seem limited to flash video though, as flash sites in general behave ok, and I can play hd content off local and networked drives.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.