Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

There is a keyboard input problem using Ubuntu 10.04 as a guest in VMWare. I found a website here that explained howto get around this problem in Kubuntu (which uses the KDM login manager.

How can I accomplish the same using regular Ubuntu 10.04 (which uses the GDM login manager)?

Edit: I have tried to use the on-screen keyboard, but it automatically closes after selecting the on-screen keyboard option from Universal Access Preferences.

share|improve this question
1  
I had the on-screen keyboard close on one VM as well. I rebooted and the keyboard was up and working next time around (Ubuntu is sometimes like Windows... cough) – Chris_K May 6 '10 at 1:07
up vote 0 down vote accepted

I used the virtual keyboard to log in the first time, then edited the same file. At the login console, click on the "little dude in a circle" icon at the bottom to access Universal Access Preferences. From there you can turn on the on-screen keyboard.

share|improve this answer
    
Indeed, the Virtual Keyboard required a reboot of my VM after enabling on my box. – csnullptr May 6 '10 at 9:30

try hitting ctrl + g. I used the virtual keyboard to login and vmware told me to hit ctrl + g to allow input, and now the keyboard input is functioning.

share|improve this answer

Follow the same procedure on ubuntu 10.04, which contains /etc/default/console-setup

share|improve this answer
    
The problem is that GDM doesn't offer the same way to exit to a console login that KDM does (that I know of). There may be a keyboard shortcut to do this, but that doesn't really help when keyboard input isn't working. I can't get the onscreen keyboard to show up either. – csnullptr May 6 '10 at 0:16
    
enable bridged networking and ssh to the guest and change it. – RainDoctor May 6 '10 at 0:24
    
It's a fresh install and I don't have ssh setup yet. Otherwise a great idea. – csnullptr May 6 '10 at 0:37
    
Well, there is another way, which I have not tried but will work. Shutdown that vm. Mount that vmdk image and change that entry. Unmount it and boot back. jameslittle.me.uk/how-to-mount-vmdk-files-in-linux – RainDoctor May 6 '10 at 0:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .