Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My machine is a recent model Systemax, less than 2 years old. It came with Vista 32bit and I bought Windows 7 Home Premium Upgrade for it. When I insert the Windows 7 DVD into the drive, it churns a little but does not recognize the disc. If I double click the DVD drive icon, it prompts me to insert a disc. I tried a different DVD (Office 2007) and the drive recognized the disc. I tried the Windows 7 disc in my Dell laptop and it recognized the disc.

So basically, the disc is good and the drive is good, but they don't like each other.

I tried to boot to the Windows 7 DVD and the system did not see it. I turned off the Lightscribe service and that didn't help.

Does anybody have an idea what's wrong here?

Thanks.

share|improve this question
    
Is the disc scratched or dirty at all? It's possible that your laptop has a higher quality disc drive and can deal with discs that have been a bit more abused than your desktop can. –  Emory Bell May 6 '10 at 1:10
    
The disc is brand new. It came out of a factory-sealed Windows 7 box. –  Ed Manet May 6 '10 at 2:18
    
Do other bootable CD/DVD disks work with the drive? –  Isxek May 6 '10 at 2:26
add comment

3 Answers

up vote 1 down vote accepted

It turned out to be the DVD drive itself. I replaced it with a new drive and it immediately recognized the disc. I have a suspicious feeling that Lightscribe was the real culprit. The only difference between the old drive and the new drive is that the new drive is not a Lightscribe drive.

Thanks to all for the help diagnosing the issue.

share|improve this answer
add comment

Mine is doing the same thing, and it does nto have lightscribe. Because we know the drive iteself is good as it reads other disks fine, and the disk is good, then it is some funky incompatibility between the drive and the disk. It is amazing we still see this issue, although not as frequent. Used to be real common several years ago. I think it really has more to do with the type of compression Microsoft is using on the DVD, possibly the security steps they have taken to prevent copying. Anyway, now I will have to swap some drives around and see if I can get one to read the darn disk so I can install WIn 7.

share|improve this answer
add comment

Couple ideas include seeing if there's a firmware update for your DVD drive model and cleaning the DVD. It is possible, although rare, that the Win7 DVD is defective. If nothing else works, see if you can exchange the DVD.

share|improve this answer
    
I tried the firmware update bu that was no help. The Win7 DVD can't be bad, as I've tried it in several other computers and they all read it. Other DVDs work in the drive, I popped an Ubuntu 10 DVD in and it read that. –  Ed Manet May 7 '10 at 13:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.