Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to prevent MySQL from starting in Ubuntu 10.04

I have used

update-rc.d -f mysql remove

and confirmed that there is no link to the /etc/inid.d/mysql script from any of the rc?.d directories.

I also ran sysv-rc-conf and it shows me that MySQL is NOT being called as part of the rc.d scripts.

It is still starting on boot. How do I disable it?

share|improve this question
    
mysqld is running under the mysql user account –  bryan May 7 '10 at 4:33
add comment

3 Answers

up vote 33 down vote accepted

Ubuntu 10.04 has abandoned SysV init script approach to booting the system.

This link explains - http://www.linuxplanet.com/linuxplanet/tutorials/7033/1/

To prevent mysql from starting on boot

  • 1 go to the /etc/init directory
  • 2. open the mysql.conf file
  • 3. comment out the "start on" line near the top of the file, the "start on" might be spread across two lines, so comment out both

If you want to manually start mysql, use the following command -

  service mysql start
share|improve this answer
    
Link is 404. Use linuxplanet.com/linuxplanet/tutorials/7033/1 –  Kevin M May 8 '10 at 15:46
    
The link is fixed, and the answer is correct. –  bryan May 8 '10 at 18:17
4  
Instead of modifying the original .conf file, better use override files: (as root)# echo "manual" >> /etc/init/mysql.override –  nh2 Oct 14 '12 at 4:00
add comment

run the command as follows:

root@user:~# gedit /etc/init/mysql.conf 

then comment out the starting lines, I think there should be two, and you are all set!

Happy Linuxing to All!

share|improve this answer
3  
/etc/init/ and /etc/init.d/ are NOT the same! I can't downvote this because I don't have the reputation, and I can't edit it because it's only a two-character change. –  alberge Mar 16 '12 at 0:38
    
@alberge - I made the edit. Waiting on peer review. –  dhulihan Mar 23 '12 at 21:09
add comment

As @nh2 mentioned in his comment there's another — a way more clear/flexible way to disable(/enable) upstart's task: «…

With Upstart 1.3, you can make use of an "override file" and the manual stanza to achieve the same result in a simpler manner:

# echo "manual" >> /etc/init/myjob.override

…»

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.