Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Setup:
Windows 7 x64 Ultimate desktop hard wired to Asus WL500gp router (WL500gpv2-1.9.2.7-d-r1445 firmware)
Several Bridged VirtualBox VM's running XP, 7, ubuntu server 10.04, Mint 9 and SuSE 11.2
Win XP Pro SP3 notebook with D-Link Airplus wireless network card.

No firewall or other security software currently running on either platform (at least for the duration of the test)

Situation:
Router is acting DHCP server
Clients are receiving correct addresses and additional parameters
Internet connectivity is available from all clients
Windows 7 sharing is set to Network type = work (not home group)
NetBT is disabled on all clients using smb over TCP

What I can do:
I can ping the router and internet addresses from the wireless XP notebook
I can ping the Win 7 desktop and any VM from the XP wireless notebook
I can ping all devices from the router
All VM's and 7 can ping each other and the router as well as Internet addresses

What I can't do:
I cannot ping the XP wireless notebook from either the Win 7 desktop or the VM's; it always returns a destination host unreachable error. Tracert resolves the name or the XP notebook but also returns a destination host unreachable.

From the above it would seem that something is blocking connectivity in a single direction (from the Win 7 box to the Win XP notebook) only but the router can ping the XP notebook.

Some fresh input would be most welcome, as this is beginning to drive me batty.

Thanks

share|improve this question
    
Don't edit the title to mark "solved", on this site. Questions which have no accepted answers will occasionally get poked to the front page. The correct way to do when you solve your own situation is to post an answer, and accept it, simply. –  Gnoupi May 19 '10 at 11:50

3 Answers 3

Go through all the settings on your router. Many that I've seen have settings which will block communication between wireless and non-wireless clients as a security precaution. About the only thing I can think of since you don't have firewall software installed.

share|improve this answer
    
Thanks for the reply. I have spent some time going through those settings and the iptables config, unfortunately, nothing jumps out at me and there are no log entries to indicate a block somewhere. Are there any specific router settings you can think of that may be playing a part here? –  Pulse May 6 '10 at 12:27
    
For example, my Belkin router, in the wireless settings tab, has a checkbox for whether or not to allow the wireless devices to see/communicate with the LAN devices. (Can't remember the exact wording). –  BBlake May 6 '10 at 12:33
    
Thanks for your help. I had some more time today so I hardwired the notebook to the router and I had instant communication. This obviously indicates a problem along the lines you suggest, I just don't seem to have an option, such as the one you describe, in my router. I can only assume it's a little less obvious. –  Pulse May 7 '10 at 10:02

Its called the DMZ in my 2Wire router.

Basically, devices not in the DMZ can communicate with each other, but not with devices in the DMZ. Devices in the DMZ can communicate with each other (and the outside world) but not with devices in the DMZ. (Unless ports are forwarded).

Perhaps try allocating your XP notebook with another IP address? Oh and check MAC filters as well. My DLink router has that feature, where computers with that MAC address who attempt to connect will stay in the "Guest" zone, where no computers in the normal network can communicate with the "Guests", and vice versa.

share|improve this answer
    
Hi, thanks for the reply. I checked the DMZ and I have nothing allocated to that region and I have ensured MAC restrictions are disabled and there are no entries in the address table. It's in there somewhere though :) –  Pulse May 7 '10 at 11:06
up vote 0 down vote accepted

In the end I reinstalled the firmware and now everything is working correctly.

Thanks for the replies. This is now closed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.