Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Asus EEE PC 1005P which I installed a Command-line system on using the Alternate Installer CD of Ubuntu Lucid Lynx. Altough I think this is a general linux and grub2 question. I do not have (or want) the X Window System installed.

I want to change my console screen resolution (not inside X) to 1024x600. But it isn't reported when I use vbeinfo inside grub:

grub> vbeinfo
VBE info:   version: 3.0  OEM software rev: 1.0
            total memory: 8128 KiB
List of compatible video modes:
Legend: P=Packed pixel, D=Direct color, mask/pos=R/G/B/reserved
0x112:   640 x 480 x 32   Direct, mask: 8/8/8/8  pos: 16/8/0/24
0x114:   800 x 600 x 16   Direct, mask: 5/6/5/0  pos: 11/5/0/0
0x115:   800 x 600 x 32   Direct, mask: 8/8/8/8  pos: 16/8/0/24
0x101:   640 x 480 x 8    Packed
0x103:   800 x 600 x 8    Packed
0x111:   640 x 480 x 16   Direct, mask: 5/6/5/0  pos: 11/5/0/0
Configured VBE mode (vbe_mode) = ox101
grub> 

Relevant parts of sudo lspci -v:

...     ...

00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller
        Subsystem: ASUSTeK Computer Inc. Device 83ac
        Flags: bus master, fast devsel, latency 0, IRQ 28
        ...
        Kernel driver in use: i915
        Kernel modules: i915

00:02.1 Display controller: Intel Corporation N10 Family Integrated Graphics Controller
        Subsystem: ASUSTeK Computer Inc. Device 83ac
        Flags: bus master, fast devsel, latency 0, IRQ 28
        ...

...     ...

Any ideas on how I can set the console resultion like I want it?

Added!

sudo fbset -i:

mode "1024x600"
    geometry 1024 600 1024 600 32
    timings 0 0 0 0 0 0 0
    rgba 8/16,8/8,8/0,0/0
endmode

Frame buffer device information:
    Name            : inteldrmfb
    Address         : 0xd0830000
    Size            : 2457600
    Type            : PACKED PIXELS
    Visual          : TRUECOLOR
    XPanStep        : 1
    YPanStep        : 1
    YWrapStep       : 0
    LineLength      : 4096
    MMIO Address    : 0xf7e00000
    MMIO Size       : 524288
    Accelerator     : No

Does it mean I have the driver? Any ideas on how to set it to 1024 x 600 in grub2?

share|improve this question

1 Answer 1

I recently ran into some similar trouble with Grub's VBE. Unfortunately, Grub cannot access any graphics modes that are not reported by your vbeinfo command. Set Grub's graphics mode by setting GRUB_GFXMODE, and the console framebuffer by setting GRUB_GFXPAYLOAD_LINUX, in /etc/default/grub and running sudo update-grub (source).

The linux console is displayed on a framebuffer device; that's what the inteldrmfb device is (shown in your fbset ouput). The framebuffer may need to be enabled in your initrd. If so, run the following to enable it:

echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash
sudo update-initramfs -u

I've seen several threads regarding configuring console framebuffers in Lucid. You may need to look into something similar. This post describes setting up uvesafb by passing specific framebuffer options on the kernel commandline. If this is needed in your case, you'd add something like "nomodeset video=intelfb:mode_option=1024x600-24,mtrr=3,scroll=ywrap" to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub. (The "intelfb" in that line may need to be "inteldrmfb", but I'm not certain.) You may also need to add a line in /etc/initramfs-tools/modules -- "intelfb mode_option=1024x600-24 mtrr=3 scroll=ywrap" -- and then re-run the update-initramfs command above.

Another alternative mentioned in the last link would be to remove the splash kernel option (from GRUB_CMDLINE_LINUX_DEFAULT), setting GRUB_GFXMODE and GRUB_GFXPAYLOAD_LINUX, and re-running update-grub.

Other resources that may help:

share|improve this answer
    
+1 The uvesafb trick on the page you mentioned made my Ubuntu 10.04 run beautifully inside a VMware server. –  karlphillip Sep 1 '10 at 14:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.