Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm a brand spanking new user of OS X, coming from a lifetime of Windows use. I've been setting up my new Macbook Pro and have run into a very unusual problem. Over wifi, I am unable to copy files to or from my Windows Home Server. The problem seems to exist only over wifi, and only to WHS.

Here are the details of my setup:

  • 2010 Macbook Pro (Core i7), OS X 10.6.3
  • Windows Home Server PP3 (virtualized in XenServer 5.5)
  • Windows 7 Ultimate x64 desktop
  • Windows 7 Ultimate x64 in Boot Camp
  • D-Link DIR-655 wireless N router

Here is what I've done to narrow down the problem:

  • Files copy fine from WHS to OS X when using gigabit ethernet
  • Files copy fine from desktop to OS X when using gigabit ethernet
  • Files fail to copy from WHS to OS X when using wifi (error -51)
  • Files copy fine from desktop to OS X when using wifi
  • Files copy fine from WHS to Boot Camp when using wifi
  • Files copy fine from desktop to Boot Camp when using wifi

From what I can tell, it seems to be some sort of issue between OS X and WHS, but I can't for the life of me see what would be different between shares on WHS and my desktop. They are both connected using smb://ADDRESS (I've tried both by IP and name). I can browse the shares on the WHS, but copying to OS X fails.

I originally found the issue while installing VS2010 off an ISO from WHS, mounted to a Windows 7 VM using VMware Fusion. During the installation the VM was unusable - even the clock got behind the host be about 8 minutes. Once I plugged in the ethernet and disabled the wifi things picked up and finished quickly. The Fusion 3.1 RC is the only I think of that I installed that may have messed with the wifi driver.

I've also tried resetting the wifi router, and have changed it from being G & N to N-only. Under Boot Camp I get similar speeds as my wife's N laptop.

Any ideas?

Thanks!

Update: The issue has been further narrowed down to Windows Server 2003, which Windows Home Server is based on, running in XenServer with the XenServer tools installed.

share|improve this question
    
How and from which side did you try to start the file copy? Which host and application said "Error 51"? Was the error message immediate or did anything happen before it appeared? –  JRobert May 7 '10 at 17:56
    
In OS X, in Finder, copying from the network share. It will start copying for a few KB, and then hang for a few minutes before erroring. I've since narrowed the issue down to accessing shares over wifi that are hosted on a virtualized Server 2003 in XenServer. Crazy, but that seems to be the issue. I'll update the question once I get more clarification. –  John Clayton May 11 '10 at 0:58
add comment

1 Answer

up vote 0 down vote accepted

Per Citrix, the solution is to disable task offloading in Windows Server 2003.

Once I made the registry change and rebooted the VM everything seems to be working fine. Files can be copied over wifi at the same speed as from other computers. OS X has no problem with the files now.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.