Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

HI all sorry for my bad English

My program (GTK) runs in Linux (Ubuntu) without any problem and its themes are fine but when I change my system to run just X and then my program, it runs but without any theme. How can I configure my system to use theme in X for my program?

REGARDS

share|improve this question

2 Answers 2

Create a .gtkrc-2.0 in your home folder. Like this:
touch ~/.gtkrc-2.0

Then you just have to edit it.
nano ~/.gtkrc-2.0

Using the documentations/howtos.
Like this or this or you can use a tool for all of this (which works more or less). (gtk-chtheme or lxappearance)

If you use your root account to start the X, then obviously you have to copy the gtkrc into the root folder. sudo cp /home/username/.gtkrc* /root/

share|improve this answer

The Ubuntu configuration tools set the theme using gnome-settings-daemon. This daemon is always running as part of a Gnome session, but if Gnome has not started, it isn't running, and so the theme settings are not applied.

You can either run gnome-settings-daemon in your X session, or manually change your GTK theme settings as suggested by Shiki.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.