Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Alright, I asked this on StackOverflow (here) and they suggested trying ServerFault to get help on permissions.

So here's the deal. We designed a custom PCI card and wrote the driver for it. It's been working for years without problems but now we encountered one particular installation were it doesn't work. The problem is that we cannot connect to the PCI to begin communication with it.

We tried replacing the card and had the same problem. We had the motherboard replaced thinking the PCI slots were bad. That didn't help either. We tried the cards in a different computer and they all worked. So it seemed to be something specific to the computer.

The Windows Device Manager indicates the device is working properly and seems to have all the correct driver info.

We now have this troublesome computer back at the office for testing. With the help of some extra debug info in the driver we determined that we cannot connect because access is denied. Sounds like a permissions issue to me.

I should note that we are logged into the system as a local administrator.

So what configuration option in Windows can prevent access to a device?

share|improve this question

migrated from serverfault.com May 7 '10 at 6:47

This question came from our site for professional system and network administrators.

1 Answer 1

I'n not sure sure what account a driver logs in as (in fact I'm pretty sure drivers do not log in) - is this a service that uses the driver? If it's a service create an account that's in the admin group and run it under that account. If it still fails keep adding rights under the local security policy (user rights asssignment) until it finally works them remove the ones prior to the one that worked. It's brute force but it's a sure way to figure out if there is a rights issue. In your other question you mentioned createfile. Make sure that the account you use has bypass traverse checking as a right and full control of the directory.

Process explorer might help you determine where things are failing

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.