Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I start up my laptop with Xubuntu on it, a Terminal window opens and just sits in the taskbar - as though I opened it myself.

Anyone know if there's some sort of list of applications which open at boot time. Maybe Terminal got on that list somehow?

share|improve this question

1 Answer 1

When you log out of Xubuntu, the little dialog that comes up with the various options (Log Out, Restart, Shutdown, etc) contains a checkbox that says "Save the current session for future logins".

If that is checked, Xubuntu saves whatever programs are running, and starts them up again the next time you log into Xubuntu. They start up in the same position they were in when you logged out. You probably logged out at some point with a minimized Terminal still running, and left that checkbox checked, and that's why it's restarting.

I normally want a terminal or two autostarted when I log in, but nothing else. So I open up my terminal windows and position them, then log out, making sure the save session checkbox is checked. Then I log in again. The next time I log out, I uncheck that checkbox so my session doesn't get overwritten.

To get rid of it, you need to

  1. log in,
  2. close the terminal and any other programs you don't want started,
  3. log out, making sure the save session checkbox is checked,
  4. log in again,
  5. if any programs start up that you don't want, go back to step 2,
  6. log out again, making sure the save session checkbox is not checked.

The next time you log in, those programs should be gone. The next time you log out, the checkbox should stay unchecked.

If this doesn't fix it, the Terminal may be starting from an xinit script (~/.xinitrc or /etc/X11/xinit/xinitrc).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.