Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to stream HD movies over my wired Gigabit LAN from my PC to my Acer Aspire Revo R3610. It's connected with a 3ft Cat5e patch cable to my Netgear GS605v2 Switch. The PC acting as File Server is connected at 1Gbps to the Switch. Network driver options are set to defaults, including automatic speed/duplex negotiation on both machines.

The Revo will not connect to my Network Switch at 1Gbps - the OS reports that it reverts to 100Mbps either shortly after connection or immediately upon connection. Through a process of elimination (trying different drivers, patch cables, ports on the switch, and other 1Gbps-capable devices connected to the Network switch which successfully achieve 1Gbps links and performance) I have drawn the conclusion there is either a Hardware or Software (Driver) issue with the Revo itself. I have performed tests using Windows 7 and Ubuntu 9.10.

Can anyone offer insight on Gigabit Ethernet with the Revo?

share|improve this question
    
Can't you just set it to connect at 1Gbps in the network settings, why have it set to automatic? –  Christopher Edwards May 7 '10 at 15:45
    
3 reasons: In Linux using ethtool forcing 1000 connection has no effect, In Windows there is no option in the speed settings for 1Gbps(!) and generally auto is encouraged to avoid duplex mismatch problems. –  The Operator May 9 '10 at 18:49
    
Most of the server NICs I've used (before gigabit desktop NICs were common) don't have an explicit 1000 mode. Gigabit can often only be achieved via the "auto negotiate" modes. –  Cylindric May 11 '10 at 8:49

1 Answer 1

up vote 1 down vote accepted

Have you tried connecting the Revo to a different gigabit switch? It might be something as simple as a faulty switch. I've seen them appear to work fine, but when that one new device is connected, it doesn't work. Could just be overloading the switch.

If you're on your Ubuntu setup try this to see if the NIC is re-negotiating a lot

tail -f /var/log/syslog

Or this to see the current settings:

ethtool eth0

If you're in Windows, open up the adapter status page and watch the connectivity and speed values.

share|improve this answer
    
Thanks for your reply! It does indeed appear after much testing and swapping around of kit that a faulty switch was at the root of the problem. –  The Operator May 11 '10 at 11:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.