Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i am having mac mini with mac os 10.4.11, with 512mb of ram and now i want to install the iphone sdk 3.2 but it is giving me error that it requir mac os 10.6.2. can i install mac os 10.6.2 with my old mac mini hardware configuration.

share|improve this question

migrated from May 7 '10 at 14:01

This question came from our site for professional and enthusiast programmers.

It depends on whether your Mac Mini is Intel or PowerPC. In the former case the answer is yes (but get more RAM), in the latter case it's no. – Paul R May 7 '10 at 7:44

3 Answers 3

Let Apple be your guide:

share|improve this answer
And btw - for comparison: – tmadsen May 7 '10 at 5:26

You might want to take a look at if you're having issues installing snow leopard on an old intel mac. If the computer is ppc (PowerPC) your out of luck.

share|improve this answer
Leopard Assist is to help with installing 10.5 on older PPCs. There is no need for a tool to help install 10.6 on older Intels, because all Intel Macs are supported already. – Coxy May 7 '10 at 5:31
That's not quite true, some of the initial macbook didn't meet the specs to run snow leopard. – Kendall Hopkins May 7 '10 at 5:34
@Kendall - all MacBooks can run 10.6, although they may not have originally shipped with enough RAM. 10.6 requires any Intel processor and 1GB RAM; and all Intel Macs can be upgraded to 2GB at least. – Coxy May 7 '10 at 8:35

10.6.2 installs onto any Intel Mac, and 10.5.8 Installer claims to require anything faster than a 867MHz G4 and 512MB of RAM, although it will technically run on less.

share|improve this answer
But the OP wishes to run the iPhone SDK, which requires an Intel processor. – Jeff Kelley May 7 '10 at 5:40
I was answering the letter of the question if perhaps not the spirit. :) – Coxy May 7 '10 at 8:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.