Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I do a search in windows 7 I cannot find any files, even though I do a search for a file i know exists (I can see the file in explorer).

The search query returns folders but not files.

Edit: I totally forgot that the drive I'm trying to do a search on is encrypted using TrueCrypt. If figured this out because when I tried to do a search on my system disk it works out fine, but not on the encrypted disk.

share|improve this question

Within explorer check this setting:

Organize -> Folder and search Options -> Search Options -> Search -> What to search

share|improve this answer

(in addition to mindless.panda's answer)

The Windows Folder Search issue that files aren't found while folders are, lies in your indexing options. You have probably unchecked some or all file extensions. Since folders can't have extensions, they will always be found regardless of your index settings.

Control Panel » Indexing options » Advanced » File types

I for myself also disabled most of those extensions, so the Start Bar search will show only .exe and .lnk files (programs: yes, junk: not) and becomes usable again.

This leads to your issue where folder search can't be used the way before. To get the best of both worlds, disable the index only for folder search queries. Mindless.panda already showed a good start, but forgot to mention the exact option:

Go to Menu bar » Tools » Folder Options » Search and enable this option

enter image description here

With index          Without index 
(only one hit)      (all possible hits)

enter image description hereenter image description here

share|improve this answer

are you searching for a system file? if you are you have to set the search settings to allow you to search for hidden and system files. otherwise when you search for system files it will now return in the search results.

share|improve this answer
Nope I'm not searching system files. I've tried different kinds of searches such as for .mp3, .avi, .jpg, .cs -files. Nothing works. – Felix May 8 '10 at 16:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .