Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently upgraded my kernel from 2.6.31-gentoo-r6 to 2.6.32-gentoo-r7. In both cases, I configured everything manually. However, since the upgrade, my wireless card appears to be on the fritz. It will connect to networks just fine, and remain connected, but can only access the internet (and other hosts on the network) for about 3 seconds after connecting. Reconnecting to the network appears to fix the problem... for another 3 seconds or so.

The problem is "solved" by booting into the older kernel. The relevant lspci entry is

02:00.0 Network controller: Intel Corporation PRO/Wireless 5300 AGN [Shiloh] Network Connection

I'm pretty sure I have the correct drivers enabled in the kernel

Device Drivers --->
    Network device support --->
        Wireless LAN (IEEE 802.11) --->
            <*>   Intel Wireless Wifi
            [*]     Enable LED support in iwlagn and iwl3945 drivers
            [*]     Enable Spectrum Measurement in iwlagn driver
            [*]     Enable full debugging output in iwlagn and iwl3945 drivers
            <*>     Intel Wireless WiFi Next Gen AGN (iwlagn)
            [*]       Intel Wireless WiFi 4965AGN
            [*]       Intel Wireless WiFi 5000AGN; Intel WiFi Link 1000, 6000, and 6050 Series

I tried recompiling the kernel with the other intel drivers enabled as well (iwl3945) and no difference. Is there something stupid I'm missing? Is there something I have to recompile after upgrading the kernel (a la nvidia)?

Sadly I cannot check the config of my old kernel as I somehow seem to have lost the makefile for it so I can't get into the menuconfig and oddly it doesn't seem to be in portage anymore.

Thanks
Mala

UPDATE:

I have noticed that under the new kernel, the "wireless killswitch" (in my case Fn-F11) doesn't seem to do anything. Possibly related?

share|improve this question
    
I would recompile the kernel. –  ta.speot.is May 9 '10 at 0:45
    
I've been doing that a whole lot –  Mala May 9 '10 at 0:51
    
did you disable /proc/config.gz in your old kernel? –  edk May 9 '10 at 0:55
    
...i don't really know what that means... is that option where the old kernel config is stored in the kernel? In any case, (booted in the old kernel) i don't have a /proc/config.gz –  Mala May 9 '10 at 1:15

1 Answer 1

up vote 0 down vote accepted

Also having a Intel 5300AGN, running Gentoo and recently upgraded to the most recent and stable gentoo-sources, but without any problems. Using the following Kernel configuration:

<M>   Intel Wireless Wifi
<M>     Intel Wireless WiFi Next Gen AGN (iwlagn)
[*]       Intel Wireless WiFi 5000AGN; Intel WiFi Link 1000, 6000, and 6050 Series

So maybe you can play around a little with the enabled options and built-in/as-module. You don't need to recompile anything after upgrading your kernel to get your Intel wireless working like you need to for nVidia cards.

What do you use to configure your wireless network, are you using wpa-supplicant? Maybe this is causing disconnects, have you tried a unencrypted network configured manually with iwconfig (just for testing of course)?

share|improve this answer
    
I use wicd, which I suppose uses wpa_supplicant (because yes, my network is wpa protected). However, I think it has to be kernel-related as using the older kernel keeps me connected. I'll try your unencrypted idea as soon as I can get to one, but my hopes aren't up... –  Mala May 9 '10 at 1:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.