Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When my netbook boots, the GRUB menu does not wait me to choose between systems. It goes automatically into Ubuntu system. How can I solve this problem?

share|improve this question
    
it would be helpful to know what version of Ubuntu you're running. (and what version of Grub, if you know it; and what version of what other operating systems you're trying to boot.) –  quack quixote May 9 '10 at 21:21

5 Answers 5

My suggestion is to get into Linux if you aren't fast enough with the escape key and the, as root (using su command ). Go to /boot/grub and edit grub.conf using a Linux editor (Vim, vi, nedit, etc) and change timeout=0 to timeout=10. The hiddenmenu command in the config file below it keep the menu hidden until you hit the escape key. All this does is delay booting for 10 seconds before bringing up the formal Linux booting screen (OS is loading up). I use 5 seconds since it's obvious I want to jump into Windows (I have a dual boot machine). Hitting escape brings up the menu and gives me the classic selection of available bootable configurations I've defined in grub.conf. My grub configuration contains the current kernel, the previous kernel and Windows.

If you don't know the intricacies of grub/grub.conf then be very careful. Only change that one numeric value—nothing else.

Make certain you save it back in Linux format (LF (Linux) and not CR/LF (DOS) format).

In Vim, it would be the ZZ command to write the file back and exit Vim (text) or just use the graphical and save and then exit. Problem solved.

share|improve this answer
    
It is not advisable to edit /boot/grub/grub.conf file directly. Instead, edit GRUB_TIMEOUT in /etc/default/grub file and regenerate grub.conf file using grub-mkconfig -o /boot/grub/grub.cfg command. –  Sanket Parmar Jul 3 at 12:04

In grub2, just press the key "shift"

share|improve this answer

The default key to get to the Grub menu is "Escape". Even if Grub is set with a timeout of 0 seconds, as long as you multi-tap Escape quickly down when starting up (after the BIOS page) you can bring up the Grub menu to change operating systems.

If Grub is always loading the wrong OS for you, you can modify it to a different entry or to use the last used entry (with the option "saved"). Modifying Grub depends on your Grub version, so it's useful to know what version of Ubuntu you are running.

share|improve this answer

Here is the recommended way to change the grub configurations. Change the GRUB_TIMEOUT value in /etc/default/grub file and regenerate /boot/grub/grub.cfg using following commands.

To edit the file

# vim /etc/defaults/grub 

Change

GRUB_TIMEOUT=10

Take backup of current grub.cfg file

# cp /boot/grub/grub.cfg /boot/grub/grub.bkup

Regerate the grub.cfg file with updated value

# grub-mkconfig -o /boot/grub/grub.cfg 
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.