Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Forgive my ignorance, for I am a complete linux noob.

I have a computer with three video cards and six monitors. Works great on Windows. Trying to get it to run Ubuntu 10.4 as well.

It loads fine when I have it configured to run on one adapter; detects both screens, runs ok. But I want to turn the other 4 monitors on and run the whole thing as one extended desktop (one session, etc).

So I downloaded and installed the newest ATI driver for Linux, which seems to work, kinda. I ran this to set up the screens:

aticonfig --adapter=all --initial -f

Now when I boot, Ubuntu seems to turn on all the screens (3 viewports, each with two cloned displays from what I can tell). When I enter my login info OR move the mouse off the main screen, the screens freeze and the kbd/ms become unresponsive.

aticonfig generated xorg.conf included below.

Have tried the following:

  • aticonfig -initial -f - works, but only detects the primary adapter and 2 screens
  • aticccle - Tells me I have to reboot after enabling the other cards. Then goes into above described freezing state.
  • aticonfig --adapter=all --initial -f - see above
  • Manually editing xorg.conf file with my limited knowledge - Was able to get two adapters running, but only the second adapter initialized while the primary stopped at the Ubuntu boot screen. Was unable to see the login prompt. Froze after I logged in blindly (was able to hear the login sound).
  • Using generic "radeon" driver instead of ATI Proprietary driver with the above init attempts
  • Toggling xinerama
  • Various combinations of the above

Hardware:

  • Intel Core 2 Quad q6600
  • 8GB DDR2
  • (3x) ATI Radeon HD 4680
  • 5 monitors (21" W, 21" W, 22" Portrait, 22"W Portrait, 19") and an HDTV (26" W, HDMI) in a horizontal arrangement

I know next to nothing about Linux/Ubuntu aside from basic filesystem navigation, editing text files, and accessing my local and networked Windows stores and shares. Basically this is the most advanced thing I've had to do. I installed today.

Please advise how to make this configuration work.

My xorg.conf:

Section "ServerLayout"  Identifier    
"Layout0"   Screen      0 
"aticonfig-Screen[0]-0" 0 0     Screen   
"aticonfig-Screen[1]-0" RightOf
"aticonfig-Screen[0]-0"     Screen       
"aticonfig-Screen[2]-0" RightOf
"aticonfig-Screen[1]-0"     Option     
"RenderAccel" "true"    Option     
"AllowGLXWithComposite" "true"
EndSection

Section "Files" EndSection

Section "Module" EndSection

Section "ServerFlags"   Option     
"Xinerama" "0" EndSection

Section "Monitor"   Identifier  
"aticonfig-Monitor[0]-0"    Option     
"VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic
Autodetecting Monitor"  Option     
"DPMS" "true" EndSection

Section "Monitor"   Identifier  
"aticonfig-Monitor[1]-0"    Option     
"VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic
Autodetecting Monitor"  Option     
"DPMS" "true" EndSection

Section "Monitor"   Identifier  
"aticonfig-Monitor[2]-0"    Option     
"VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic
Autodetecting Monitor"  Option     
"DPMS" "true" EndSection

Section "Device"    Identifier 
"aticonfig-Device[0]-0"     Driver     
"fglrx"     BusID       "PCI:1:0:0"
EndSection

Section "Device"    Identifier 
"aticonfig-Device[1]-0"     Driver     
"fglrx"     BusID       "PCI:3:0:0"
EndSection

Section "Device"    Identifier 
"aticonfig-Device[2]-0"     Driver     
"fglrx"     BusID       "PCI:4:0:0"
EndSection

Section "Screen"    Identifier
"aticonfig-Screen[0]-0"     Device    
"aticonfig-Device[0]-0"     Monitor   
"aticonfig-Monitor[0]-0"    DefaultDepth
24  SubSection "Display"        Viewport  
0 0         Depth     24    EndSubSection
EndSection

Section "Screen"    Identifier
"aticonfig-Screen[1]-0"     Device    
"aticonfig-Device[1]-0"     Monitor   
"aticonfig-Monitor[1]-0"    DefaultDepth
24  SubSection "Display"        Viewport  
0 0         Depth     24    EndSubSection
EndSection

Section "Screen"    Identifier
"aticonfig-Screen[2]-0"     Device    
"aticonfig-Device[2]-0"     Monitor   
"aticonfig-Monitor[2]-0"    DefaultDepth
24  SubSection "Display"        Viewport  
0 0         Depth     24    EndSubSection
EndSection
share|improve this question
1  
Sorry mate but you should just give up. :D Under Linux, Nvidia may be the only viable option when it comes to complex display setups. ATI was always the worst there in EVERY aspect, they write the worst driver, the worse support is theirs, etc. Thats why there are no games for linux, no normal video accel, no normal.. eh I wont list it. (I really dont mean this as trolling, I know what I'm talking about (speaking out from experience, and nah I don't hate ATI cards, nor I am an NVidia fan)). –  Shiki May 10 '10 at 8:21
    
@Fujishiro: So you're saying ATI is to blame for Linux's lack of good gaming? Now that would make an interesting article! –  tsilb May 10 '10 at 14:45
    
It wouldnt make a good article since its a common fact sadly. Only NVidia's blog driver is the only usable solution under linux, thats why the big companies wont meddle with it. It would be only bad for the customers and it would ruin the company's reputation. –  Shiki May 10 '10 at 15:43
    
I had a similar problem once trying to get 3 monitors working in ubuntu with 2 graphics cards - both using different drivers (one Nvidia one Intel). It was hell. And I never did get it working. Worked flawlessly in XP though. –  Fopedush Jun 11 '10 at 22:16

2 Answers 2

I can't add a comment. So I'll ask here:

  • Have you tried the open source
  • drivers? Do you want 3D acceleration?

I have the ATI close source drivers working fine. Of course when they do lock up, they take the whole system down. It's the same with Nvidia drivers. That's why the closed source drivers are not so good. If you are not after the fastest 3D acceleration, I would go for the open source drivers. The are more stable and supposed to have better dual head support.

Post back, and hopefully we can crack this one.

share|improve this answer
    
- Yes I have; - Yes I do Do you have them working fine on a three-adapter configuration? I had dual heads working fine; I'm going for the six heads that work on Windows. –  tsilb Jul 23 '10 at 23:37
    
So dual cards worked, but three does not. Do you want to try the open source driver? Or is 3D for high quality gaming a priority? –  d-_-b Jul 28 '10 at 1:50

I don't think there's any problem with the configuration. If it is the latest version of Ubuntu, then it may be that random freeze bug. It has been affecting a lot of people. I had seen a thread about the same on ubuntuforums.org which had over 500 replies.

I suggest you try fedora or downgrade to an older version of ubuntu, if you're using the latest version of ubuntu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.