Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

GNU Emacs 23.1.1

I've noticed that if I run Emacs and M-x server-start, I can use the emacsclient program as usual, but if if I start Emacs using emacs --daemon and then try to use emacsclient the new frame locks up and the shell outputs *ERROR*: Arithmetic error.

This issue doesn't happen if I use the -t flag to force terminal mode when running emacsclient.

Has anyone run into this before? Anyone know what's going on and/or how to fix it?

share|improve this question
Try to run emacs --deamon -q to skip your .emacs, or emacs --deamon -Q to skip site file. If it work with the first one, then the problem is in the .emacs, if only the second one work, then the problem is with one of the package installed on your distribution, if both failed, the problem is with your version of .emacs. – Rémi May 10 '10 at 9:09
up vote 1 down vote accepted

Turns out this is (or, at least, seems to be) a variation of an issue I've had previously. For some reason the line

'(default ((t (:background "black" :foreground "white"))))

in my custom faces settings causes a lot of problems. Before it would just throw an error and complain about a color not existing whenever I ran emacsclient -c, but now it was completely freezing the frame.

I wasn't using any custom color theme when I originally added those settings, but now that I am it looks like I can remove it without any side-effects.

share|improve this answer
Strangely, I was getting Arithmetic error in GNU Emacs for Mac OS X 24.3 (9.0) when editing python code. When I removed the custom-faces section from my .emacs it solved the problem. I also had :background "Black" :foreground "White" in there along with other things. I replaced them with a -rv command-line option. – Douglas B. Staple Oct 3 '13 at 14:18

Amazingly, this exact custom option was the cause of the pb for me too, even though I use a lot of other faces customization, this is the only one to remove in order to run emacsclient -c

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.