Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I was using my Mac Mini and decided to set the application button on Logic Click mouse to open Exposé. I had this set up at one time and found it useful. So I open the Exposé control panel and took a look at the triggers for Exposé. There is drop down for a secondary trigger. In that drop down there was a ton of mouse buttons 100+. So I selected #32 just to see what button #32 was on my 5 button mouse.

Turns out it's all of them!

Headdesk

So no matter what button I press guess what happens... I get Exposé.

So using the just the keyboard how do I:

  1. Change the Exposé trigger?

    I can use the keyboard to bring up the control Exposé panel but guess what I can't get anything else to come in to focus.

  2. Kill Exposé?

Right now all I can say is D'oh!

Any ideas?

EDIT

Also I should mention it is an older PowerPC G4 processor.

Booting into safe mode doesn't help.

share|improve this question
add comment

4 Answers

up vote 6 down vote accepted

Control-F7 is a toggle that will "Change the way Tab moves focus" -- either between text boxes and lists only, or all controls. You want the latter.

Note that with some keyboards that put other functions on the F-keys -- I have Rewind -- you also have to press fn; so fn-Control-F7 should let you Tab to those popups. Space to open the popup, arrow to the selection and Return.

share|improve this answer
    
D'oh, I don't know why I didn't think of this much simpler solution. I just tested it your way and it works perfectly (you can get to the Expose and Spaces preferences pane via Spotlight, Cmd-Space) –  Stephen Jennings May 10 '10 at 14:33
    
That did the trick. –  NitroxDM May 10 '10 at 17:35
add comment

The settings you changed are stored in the com.apple.symbolichotkeys plist. If you have the Developer Tools installed, you can open a Terminal window (Command-Space to open Spotlight, type "Terminal"), then type:

open ~/Library/Preferences/com.apple.symbolichotkeys.plist

This will open the Propery List Editor. You can use the arrow keys to find entry 32 and delete the entire entry with the delete key. Save with Command-S, then log out with Shift-Command-Q. When you log back in, you should have the default setting for the "All Windows" Expose hotkey. (The other Expose settings are numbers 32-37, as mentioned here)

If you don't have the Property List Editor installed, you can just rename/delete ~/Library/Preferences/com.apple.symbolichotkeys.plist using Terminal, but you'll lose all hotkey settings you've customized. If it's worth it to you, you can rename the plist to get your profile working again, install the Developer Tools, edit the plist with the Property List Editor, then copy that modified plist back into ~/Library/Preferences. That way all your hotkeys except Expose will come back.

share|improve this answer
    
I will file this one under "good to know"! –  NitroxDM May 10 '10 at 17:34
add comment

Set up the login preferences so that you type the username, instead of selecting a user from the list of users. Then, log in as username ">console" without a password. You'll then be dumped to the command line-only interface....no mouse!

If you want to get really crazy, you can install X11 and Gnome/KDE/Enlightenment/etc and then run startx to get a Linux/Unix GUI on OS X.

share|improve this answer
add comment

I don't really use mac, but since nobody's answered this for 2hours I'll tell you how it's done in linux, and maybe that'll help you.

One way would be to:

  1. Bring up the main applications menu (start menu).
  2. Select and open the terminal.
  3. List all processes.
  4. Find and kill the Exposé process (if there is one). If there is no exposé process, I frankly have no idea what you can do.

EDIT: Turns out there is no main applications menu in OSX. Therefor, this post is entirely useless. Please ignore it and move on.

share|improve this answer
    
Sorry, this isn’t helpful. OS X has no start menu; if there was one it would not be clickable due to the problem the user is trying to solve. There is no Exposé process (it’s part of the Dock). Alt-F1 doesn’t do anything like what it does on Linux, etc. Mac ≠ Linux. –  Nate May 10 '10 at 6:40
    
Ok, sorry for the useless post. In my defense, my instructions did not inlude any mouse clicking. The main applications menu has a hotkey assigned to it on both Windows and Ubuntu. –  Bruce Connor May 11 '10 at 0:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.