Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

There's no way to select Heading 2 (and higher). Suggestions on how to fix this are welcome.

It doesn't change when I creating documents from other templates.

share|improve this question
2  
Does the Heading 2 style exist? Has it been accidentally deleted? – Velociraptors May 10 '10 at 14:31
    
I have no idea, but if it was deleted, how can I get it back? Is there a way to reset all styles? – Sander Rijken May 10 '10 at 18:40

Word 2007 does the same, and it's really irritating.

Here's my style list on opening a new doc, not very helpful.
Word 2007 "Styles" box showing "Clear All", "Heading 1" and "Normal" only

Click the button at the bottom, the one on the right, to open the "Manage Styles icon Manage Styles".

  1. Click the Recommend tab
  2. scroll to Heading 1 and its friends, select those that you want visible and
  3. click the Show button.
  4. (optional) If you also select the New documents based on this template option at the bottom this change will happen for all new documents as well.

Here's a screenshot:
Word 2010 "Manage Styles" window, showing the steps described in the text
here's another one

share|improve this answer
    
This wasn't the problem, but it might help others – Sander Rijken Sep 30 '10 at 11:03
    
@Sander Damn. Did you have a look at the other tabs, in case there was anything there that was the cause? And so I take it that the problem was deeper than that style just lacking visibilty? Do you have any more specifics available? – DMA57361 Sep 30 '10 at 11:09
1  
awesome, that helped me out a lot – cc0 Feb 1 '11 at 11:26
    
@DMA57361: you wrote "to open the "Style Inspector"" - but this is the "Manage Styles" window, NOT "Style Inspector". Anyway, your post was really useful, it helped me, too! +1 for that! – Sk8erPeter Nov 13 '12 at 12:58
1  
@sk8erpeter Your last screenshot didn't load, so I left the "ugly" one in. By the way, we love freehand circles around here. – slhck Nov 14 '12 at 9:09

you should push ctrl+alt+2 then you get heading 2, goodluck

share|improve this answer
    
Thanks! This is much easier than changing the options (and there's no 'options' link in my Word 2010 anyway). – Will Sheppard Jul 15 '12 at 15:05

In Word 2010 right click on the Styles ribbon (or left click on the arrow in the lower right of the Styles ribbon), select options, and then check the box "Show next heading when previous level is used".

share|improve this answer
up vote 2 down vote accepted

The problem in this case was caused by shared templates. Somehow the template got messed up, and all headings but Heading 1 were gone from the template.

share|improve this answer

This can happen if you've previously hidden a style explicitly. It seems like there's a hidden setting that gets toggled when you do that, that will prevent 'Hide Until Used' from working.

If this has been done in a template, you might find this page helpful. There is a way to undo it but it involves unzipping the document and messing with XML. This is probably only worth it if your template has other settings that would be difficult or time-consuming to recreate. Content copied here, including spelling/grammar mistakes.

1. Open your document (*.docx) with '7-Zip'.
2. Navigate to 'word' folder.

Modifying 'styles.xml' will do the hiding as default. Here I wanted to remove Heading 5 and 6.

3. Extract 'styles.xml' and open it on a text editor (such as Notepad++)
4. Find w:styleId="Heading5" and remove the '<w:style w:type="paragraph" w:styleId="Heading5"> ... </w:style>' node.

Do the similar for heading 6.

5. Find w:styleId="Heading5Char" and remove the '<w:style w:type="character" w:customStyle="1" w:styleId="Heading6Char"> ... </w:style>' node.

Do the similar for heading 6.

6. Save 'styles.xml' and replace the existing 'styles.xml' in 7-zip (by drag and drop).

That's it.. Close the 7-zip window and open the file.

I had to do this for every style starting with Heading 3, to get Heading 3 to show up as the 'next style'. Note that this will wipe out any formatting changes you've made to these styles previously.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .