Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with windows 7 64-bit. I was trying out chkdsk command line options and scheduled a chddsk /r on next start. After that I disassembled the laptop on which I set the chkdsk. After I reassembled it, windows gets normally to the point where it should start the check and then hangs when the countdown reaches 1 second. During the countdown, it doesn't detect any input from keyboard. At first I thought that I didn't correctly install the keyboard, but under GNU/Linux, everything is working fine and I can normally mount the windows partition .

So is there any way to stop the scheduled chkdsk? I really don't feel like reinstalling windows again because I just finished setting up my tool-chain the way I like it and compiled about 6GiB worth of dependencies I need for some project I'm working on.

share|improve this question
    
We had a very similar problem, CHKDSK would run at every boot. Eventually, we let it run overnight, and i think it gets past the initial setup or initial analysis and then will let you stop it from the keyboard. How long are you waiting? –  Knox May 10 '10 at 11:34
    
Another thought, have you tried hooking up a USB keyboard? –  Knox May 10 '10 at 11:35
    
I'll try now with USB keyboard. As for waiting, I waited about 5 minutes. After about two minutes the HDD LED powered down, so I thought that the check hung. –  AndrejaKo May 10 '10 at 11:42
    
USB keyboard solved the problem. I still don't understand why it wouldn't detect the PS/2 internal keyboard... Everything is working fine now. –  AndrejaKo May 10 '10 at 12:04

3 Answers 3

up vote 1 down vote accepted

I'll put my answer of using a USB keyboard here (since it worked) It was possible that in rebuilding the laptop that it needed to do something to recognize the internal keyboard that would occur after the chkdsk.

share|improve this answer

There is a Microsoft article that describes How to Cancel CHKDSK After It Has Been Scheduled, with a little gotcha. The way to do it is to update the registry:

  1. Run the Registry Editor (Regedt32.exe). You must use Regedt32 and not Regedit.exe
  2. Goto HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
  3. Change the BootExecute value from:
    autocheck autochk * /r\DosDevice\<drive letter>:
    To:
    autocheck autochk *

The gotcha is of course that you can't boot and call Regedt32 to modify the registry.
The possibilities are:

  1. Use the recovery console to edit the registry. The following article was written for XP but is probably still valid.
  2. The Offline NT Password & Registry Editor boot cd claims to contain a registry editor.
  3. Do In-place Upgrade to repair the system, if all other advice has failed (this won't destroy your existing system setup).
share|improve this answer

You can skip the CHKDSK by pushing a key, but you know this already. If you go into BIOS you can try disabling "USB Aware Operating System". This will make the BIOS emulate a PS2 keyboard for your OS. Then you should be able to push keys before the CHKDSK.

Otherwise, boot into safe mode and try this.

share|improve this answer
    
I have an Acer laptop which uses the evil Insyde H20 UEFI which doesn't have any useful settings available for user to change. I even had to modify the UEFI image in order to enable Intel VT-x. I'll try safe mode now. –  AndrejaKo May 10 '10 at 11:51
    
Sorry, missed that you were using a laptop. –  ta.speot.is May 10 '10 at 13:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.